python-jdcal: restore & update removed package
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Tue, 14 May 2019 19:59:33 +0000 (16:59 -0300)
committerEneas Queiroz <cote2004-github@yahoo.com>
Tue, 21 May 2019 13:53:52 +0000 (10:53 -0300)
This is a dependency of the openpyxl package.

The package Makefile was reworked, and a python3 variant was added.
Maintainer was changed to Alexandru Ardelean & Eneas U de Queiroz.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
lang/python/python-jdcal/Makefile [new file with mode: 0644]

diff --git a/lang/python/python-jdcal/Makefile b/lang/python/python-jdcal/Makefile
new file mode 100644 (file)
index 0000000..e43c70a
--- /dev/null
@@ -0,0 +1,64 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-jdcal
+PKG_VERSION:=1.4.1
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Eneas U de Queiroz <cote2004-github@yahoo.com>
+PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE_FILES:=LICENSE.txt
+
+PKG_SOURCE:=jdcal-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/j/jdcal
+PKG_HASH:=472872e096eb8df219c23f2689fc336668bdb43d194094b5cc1707e1640acfc8
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-jdcal-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../python-package.mk
+include ../python3-package.mk
+
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
+define Package/python-jdcal/Default
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Julian dates from proleptic Gregorian and Julian calendars
+  URL:=https://github.com/phn/jdcal
+endef
+
+define Package/python-jdcal
+$(call Package/python-jdcal/Default)
+  DEPENDS:= +PACKAGE_python-jdcal:python-light
+  VARIANT:=python
+endef
+
+define Package/python3-jdcal
+$(call Package/python-jdcal/Default)
+  DEPENDS:= +PACKAGE_python3-jdcal:python3-light
+  VARIANT:=python3
+endef
+
+define Package/python-jdcal/description
+  This module contains functions for converting between Julian dates and calendar dates.
+endef
+
+define Package/python3-jdcal/description
+$(call Package/python-jdcal/description)
+.
+(Variant for Python3)
+endef
+
+$(eval $(call PyPackage,python-jdcal))
+$(eval $(call BuildPackage,python-jdcal))
+$(eval $(call BuildPackage,python-jdcal-src))
+
+$(eval $(call Py3Package,python3-jdcal))
+$(eval $(call BuildPackage,python3-jdcal))
+$(eval $(call BuildPackage,python3-jdcal-src))