Update to 7.17.1 and add tftp support
authorPeter Nixon <listuser@peternixon.net>
Fri, 28 Dec 2007 18:12:32 +0000 (18:12 +0000)
committerPeter Nixon <listuser@peternixon.net>
Fri, 28 Dec 2007 18:12:32 +0000 (18:12 +0000)
SVN-Revision: 10004

libs/curl/Makefile
libs/curl/patches/500-configure_cross.patch [deleted file]

index b79b372e06a25c47228a2e32451e7ea8f462f09b..1bf08cf2a017686350a9928c9289fb6c7179c87e 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.14.0
+PKG_VERSION:=7.17.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -20,7 +20,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=46ce665e47d37fce1a0bad935cce58a9
+PKG_MD5SUM:=1fa635d1dfde8337c98c82749d75c1de
 
 PKG_FIXUP = libtool
 
@@ -65,12 +65,15 @@ CONFIGURE_ARGS += \
        --disable-manual \
        --disable-sspi \
        --disable-telnet \
+       --enable-tftp \
        --disable-verbose \
        --with-random="/dev/urandom" \
        --with-ssl="$(STAGING_DIR)/usr" \
        --without-ca-bundle \
        --without-gnutls \
+       --without-krb4 \
        --without-libidn \
+       --without-nss \
        --with-zlib="$(STAGING_DIR)/usr" \
        --disable-gssapi
 
diff --git a/libs/curl/patches/500-configure_cross.patch b/libs/curl/patches/500-configure_cross.patch
deleted file mode 100644 (file)
index 7fa921c..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-diff -ruN curl-7.14.0-old/configure curl-7.14.0-new/configure
---- curl-7.14.0-old/configure  2005-05-14 00:23:47.000000000 +0200
-+++ curl-7.14.0-new/configure  2005-09-02 02:03:38.000000000 +0200
-@@ -26132,10 +26132,10 @@
-   fi
--  if test "$OPENSSL_ENABLED" = "1"; then
--                LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$EXTRA_SSL/lib$libsuff"
--    export LD_LIBRARY_PATH
--  fi
-+#  if test "$OPENSSL_ENABLED" = "1"; then
-+#                LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$EXTRA_SSL/lib$libsuff"
-+#    export LD_LIBRARY_PATH
-+#  fi
- fi
-@@ -26325,8 +26325,8 @@
- echo "$as_me: detected GnuTLS version $version" >&6;}
--        LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
--        export LD_LIBRARY_PATH
-+#        LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
-+#        export LD_LIBRARY_PATH
-       fi
-     fi
-diff -ruN curl-7.14.0-old/configure.ac curl-7.14.0-new/configure.ac
---- curl-7.14.0-old/configure.ac       2005-05-13 23:19:21.000000000 +0200
-+++ curl-7.14.0-new/configure.ac       2005-09-02 02:03:45.000000000 +0200
-@@ -917,13 +917,13 @@
-   fi
--  if test "$OPENSSL_ENABLED" = "1"; then
--    dnl when the ssl shared libs were found in a path that the run-time linker
--    dnl doesn't search through, we need to add it to LD_LIBRARY_PATH to
--    dnl prevent further configure tests to fail due to this
--    LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$EXTRA_SSL/lib$libsuff"
--    export LD_LIBRARY_PATH
--  fi
-+#  if test "$OPENSSL_ENABLED" = "1"; then
-+#    dnl when the ssl shared libs were found in a path that the run-time linker
-+#    dnl doesn't search through, we need to add it to LD_LIBRARY_PATH to
-+#    dnl prevent further configure tests to fail due to this
-+#    LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$EXTRA_SSL/lib$libsuff"
-+#    export LD_LIBRARY_PATH
-+#  fi
- fi
-@@ -1021,8 +1021,8 @@
-         dnl LD_LIBRARY_PATH to prevent further configure tests to fail
-         dnl due to this
--        LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
--        export LD_LIBRARY_PATH
-+#        LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlsprefix/lib$libsuff"
-+#        export LD_LIBRARY_PATH
-       fi
-     fi