vim: variants conflict with each other
authorKarel Kočí <cynerd@email.cz>
Mon, 22 Aug 2022 12:31:21 +0000 (14:31 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Wed, 24 Aug 2022 06:25:17 +0000 (08:25 +0200)
This adds conflicts between the variants,
because they provide the same files, and it should not be
possible to install them side by side. Otherwise, it might happen that
half files would be from one variant and the other half from the
other.

Also, adds provides as if you request to install ``vim`` and
``vim-full``, then the request could be satisfied even they collide,
because ``vim-full`` provides ``vim`` package.

Signed-off-by: Karel Kočí <cynerd@email.cz>
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
[add commit message]
(cherry picked from commit 46c058468aeaf7747c2e94e579020aa7f595c649)

utils/vim/Makefile

index 1c27a6161f743bcf8f684b5771c0889d463d4dc1..3681142df51e2057243bd2bfcdcac8d30641f0df 100644 (file)
@@ -41,12 +41,16 @@ endef
 define Package/vim-full
   $(call Package/vim/Default)
   TITLE+= (Normal)
+  PROVIDES:=vim
+  CONFLICTS:=vim
 endef
 
 
 define Package/vim-fuller
   $(call Package/vim/Default)
   TITLE+= (Big)
+  PROVIDES:=vim vim-full
+  CONFLICTS:=vim vim-full
 endef
 
 define Package/vim-runtime