serdisplib: fix build on macos
authorSergey V. Lobanov <sergey@lobanov.in>
Wed, 12 Jan 2022 13:25:40 +0000 (16:25 +0300)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 12 Jan 2022 18:51:51 +0000 (18:51 +0000)
./configure script detects if serdisplib is built on non-linux build
host and disables framebuffer driver. It blocks touchscreen_tool
compilation. This detection is not required on cross-compile build
so it is disabled via ac_cv_build=$(GNU_TARGET_NAME) in Makefile

Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
libs/serdisplib/Makefile

index 07978d01ae97ba881abd686bfd95cc53db1aaac0..8b36a4a51c9a7a463dbca84bea5bf64d0978c4bf 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=serdisplib
 PKG_VERSION:=2.02
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/serdisplib
@@ -51,6 +51,9 @@ define Package/serdisplib-tools/description
  * touchscreen_tool
 endef
 
+CONFIGURE_VARS += \
+       ac_cv_build=$(GNU_TARGET_NAME)
+
 CONFIGURE_ARGS += \
        --enable-dynloading \
        --disable-statictools