kirkwood: add hwmon-tc654
authorZoltan HERPAI <wigyori@uid0.hu>
Thu, 16 Jul 2020 15:46:44 +0000 (17:46 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Sun, 24 Jan 2021 23:05:39 +0000 (00:05 +0100)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/kirkwood/modules.mk [new file with mode: 0644]

diff --git a/target/linux/kirkwood/modules.mk b/target/linux/kirkwood/modules.mk
new file mode 100644 (file)
index 0000000..1b57670
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/hwmon-tc654
+  TITLE:=TC654 monitoring support
+  KCONFIG:=CONFIG_SENSORS_TC654
+  FILES:=$(LINUX_DIR)/drivers/hwmon/tc654.ko
+  AUTOLOAD:=$(call AutoLoad,60,tc654)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-tc654/description
+ Kernel module for Microchip TC654/TC655 and compatibles
+endef
+
+$(eval $(call KernelPackage,hwmon-tc654))