Update pure-ftpd to 1.0.22, and enable virtualchroot (#4046)
authorFlorian Fainelli <florian@openwrt.org>
Wed, 29 Oct 2008 13:11:18 +0000 (13:11 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 29 Oct 2008 13:11:18 +0000 (13:11 +0000)
SVN-Revision: 13072

net/pure-ftpd/Makefile
net/pure-ftpd/patches/001-cross_compile.patch

index d05172130cdc31c7acf2448f32f57ce7045e1238..7ce6c9225bb891a01fc57ca4b3b427ba88f88db1 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pure-ftpd
-PKG_VERSION:=1.0.21
+PKG_VERSION:=1.0.22
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://download.pureftpd.org/pub/pure-ftpd/releases/
-PKG_MD5SUM:=ca8a8dbec0cd9c8ea92fc4c37ea9c410
+PKG_SOURCE_URL:=http://download.pureftpd.org/pub/pure-ftpd/releases/snapshots/
+PKG_MD5SUM:=68308d7143aea092356f910859785e4a
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -36,6 +36,7 @@ endef
 
 CONFIGURE_ARGS += \
        --with-everything \
+       --with-virtualchroot \
 
 define Package/pure-ftpd/install
        $(INSTALL_DIR) $(1)/etc/config $(1)/etc/init.d $(1)/usr/sbin
index 6152d8d1a5b73fb805d6f36a1b59017cc19b2422..e531b20af9015cedc1a6ffef583ddf15ec3c6f08 100644 (file)
@@ -1,53 +1,53 @@
-Index: pure-ftpd-1.0.21/configure
+Index: pure-ftpd-1.0.22.orig/configure
 ===================================================================
---- pure-ftpd-1.0.21.orig/configure    2007-10-14 22:03:46.000000000 +0200
-+++ pure-ftpd-1.0.21/configure 2007-10-14 22:03:46.000000000 +0200
-@@ -9273,7 +9273,7 @@
-   if test "$cross_compiling" = yes; then
-   { { echo "$as_me:$LINENO: error: internal error: not reached in cross-compile" >&5
echo "$as_me: error: internal error: not reached in cross-compile" >&2;}
+--- pure-ftpd-1.0.22.orig/configure    2006-04-25 10:39:45.000000000 +0300
++++ pure-ftpd-1.0.22/configure 2008-09-26 20:01:04.000000000 +0300
+@@ -9286,7 +9286,7 @@
+ See \`config.log' for more details." >&5
+ echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
 -   { (exit 1); exit 1; }; }
 +   }
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -9679,7 +9679,7 @@
-   if test "$cross_compiling" = yes; then
-   { { echo "$as_me:$LINENO: error: internal error: not reached in cross-compile" >&5
echo "$as_me: error: internal error: not reached in cross-compile" >&2;}
+@@ -9700,7 +9700,7 @@
+ See \`config.log' for more details." >&5
+ echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
 -   { (exit 1); exit 1; }; }
 +   }
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -10085,7 +10085,7 @@
-   if test "$cross_compiling" = yes; then
-   { { echo "$as_me:$LINENO: error: internal error: not reached in cross-compile" >&5
echo "$as_me: error: internal error: not reached in cross-compile" >&2;}
+@@ -10114,7 +10114,7 @@
+ See \`config.log' for more details." >&5
+ echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
 -   { (exit 1); exit 1; }; }
 +   }
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -10491,7 +10491,7 @@
-   if test "$cross_compiling" = yes; then
-   { { echo "$as_me:$LINENO: error: internal error: not reached in cross-compile" >&5
echo "$as_me: error: internal error: not reached in cross-compile" >&2;}
+@@ -10528,7 +10528,7 @@
+ See \`config.log' for more details." >&5
+ echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
 -   { (exit 1); exit 1; }; }
 +   }
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -10897,7 +10897,7 @@
-   if test "$cross_compiling" = yes; then
-   { { echo "$as_me:$LINENO: error: internal error: not reached in cross-compile" >&5
echo "$as_me: error: internal error: not reached in cross-compile" >&2;}
+@@ -10942,7 +10942,7 @@
+ See \`config.log' for more details." >&5
+ echo "$as_me: error: cannot run test program while cross compiling
See \`config.log' for more details." >&2;}
 -   { (exit 1); exit 1; }; }
 +   }
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -21379,7 +21379,7 @@
+@@ -21513,7 +21513,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -56,7 +56,7 @@ Index: pure-ftpd-1.0.21/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -21453,7 +21453,7 @@
+@@ -21587,7 +21587,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -65,7 +65,7 @@ Index: pure-ftpd-1.0.21/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -21521,7 +21521,7 @@
+@@ -21655,7 +21655,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -74,7 +74,7 @@ Index: pure-ftpd-1.0.21/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -21627,7 +21627,7 @@
+@@ -21761,7 +21761,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -83,7 +83,7 @@ Index: pure-ftpd-1.0.21/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -21696,7 +21696,7 @@
+@@ -21830,7 +21830,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -92,7 +92,7 @@ Index: pure-ftpd-1.0.21/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -22483,7 +22483,7 @@
+@@ -22624,7 +22624,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}
@@ -101,7 +101,7 @@ Index: pure-ftpd-1.0.21/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -22886,7 +22886,7 @@
+@@ -23031,7 +23031,7 @@
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&2;}