cyrus-sasl: install module symbolic links of form libX.so
authorW. Michael Petullo <mike@flyn.org>
Mon, 13 Jan 2020 18:57:57 +0000 (13:57 -0500)
committerW. Michael Petullo <mike@flyn.org>
Mon, 13 Jan 2020 18:57:57 +0000 (13:57 -0500)
I was too aggressive in recommending that we remove the module symbolic
links of form libX.so as part of commit c9ce769b. It turns out that at
least Postfix relies on these, and I suspect any application that makes
use of libsasl2 will require them too.

Signed-off-by: W. Michael Petullo <mike@flyn.org>
libs/cyrus-sasl/Makefile

index a14b5030cf9885af5987f1c3ee31665b97982f8c..f0ae3c21851b62a0a5d53b86ea5a1bd907389f5f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cyrus-sasl
 PKG_VERSION:=2.1.27
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
@@ -109,7 +109,7 @@ define Package/libsasl2/install
        $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsasl2.so.* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/sasl2
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.so.* $(1)/usr/lib/sasl2/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.so* $(1)/usr/lib/sasl2/
 endef
 
 $(eval $(call BuildPackage,libsasl2))