ovn: include ovn-appctl
authorYousong Zhou <yszhou4tech@gmail.com>
Thu, 27 Aug 2020 05:20:11 +0000 (13:20 +0800)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 27 Aug 2020 05:58:39 +0000 (13:58 +0800)
Required by ovn-ctl for stopping ovn ovsdb instances

This utility was introduced since 20.03.0 after the project was
maintained in its own repo

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
net/ovn/Makefile

index 68b96132e5bc5fb817548eefae6fd0bd793fb0a4..f41788e12c010ce148f233420c816772af332c19 100644 (file)
@@ -10,7 +10,7 @@ include ../openvswitch/openvswitch.mk
 
 PKG_NAME:=ovn
 PKG_VERSION:=20.06.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/ovn-org/ovn.git
@@ -47,7 +47,7 @@ ovs_ovn-common_depends+=+libatomic
 ovs_ovn-common_files:= \
        usr/share/ovn/scripts/ovn-ctl \
        usr/share/ovn/scripts/ovn-lib \
-       $(foreach b,ovn-nbctl ovn-sbctl,usr/bin/$(b))
+       $(foreach b,ovn-appctl ovn-nbctl ovn-sbctl,usr/bin/$(b))
 define ovs_ovn-common_install
        $$(LN) /usr/share/openvswitch/scripts/ovs-ctl-wrapper $$(1)/usr/bin/ovn-ctl
 endef