kismet: fix compilation under uClibc-ng and GCC10
authorRosen Penev <rosenp@gmail.com>
Mon, 31 Aug 2020 07:33:41 +0000 (00:33 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 31 Aug 2020 07:39:54 +0000 (00:39 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/kismet/Makefile
net/kismet/patches/040-uclibc.patch [new file with mode: 0644]

index baacf6e4683d5a69cf485b55835de8568564c5dc..4a0e624a7645acd838c3d0f37efeaa4d4f99af1d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kismet
 PKG_VERSION:=2016-07-R1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_LICENSE:=LGPLv2.1
 PKG_CPE_ID:=cpe:/a:kismet:kismet
diff --git a/net/kismet/patches/040-uclibc.patch b/net/kismet/patches/040-uclibc.patch
new file mode 100644 (file)
index 0000000..f63a5da
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/ipc_remote.cc
++++ b/ipc_remote.cc
+@@ -941,8 +941,8 @@ int RootIPCRemote::OpenFDPassSock() {
+ }
+ typedef struct {
+-      struct cmsghdr header;
+       int            fd;
++      struct cmsghdr header;
+ } __attribute__((packed)) cmsg_fd;
+ int RootIPCRemote::SendDescriptor(int in_fd) {