git: Update to version 2.23.0
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Sat, 19 Oct 2019 23:58:02 +0000 (01:58 +0200)
committertripolar <tripolar@users.noreply.github.com>
Sun, 20 Oct 2019 10:53:29 +0000 (12:53 +0200)
Refresh patches

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
net/git/Makefile
net/git/patches/100-configure_for_crosscompiling.patch
net/git/patches/200-imapsend_without_curl.patch
net/git/patches/300-openssl-deprecated.patch

index 42a1adc3dbfae42331686e8460a2a5754b42728f..725a965ae1c67f68dcc8eb52359d128d0cb77b8a 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=git
-PKG_VERSION:=2.22.0
+PKG_VERSION:=2.23.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/software/scm/git/
-PKG_HASH:=159e4b599f8af4612e70b666600a3139541f8bacc18124daf2cbe8d1b934f29f
+PKG_HASH:=234fa05b6839e92dc300b2dd78c92ec9c0c8d439f65e1d430a7034f60af16067
 
 PKG_INSTALL:=1
 PKG_FIXUP:=autoreconf
index 07796e6df6cd2165fc9f0476509006402b5357ed..bb7a61d132b59a0811ca91f28dd0149ddfe4b41e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -929,7 +929,8 @@ AC_RUN_IFELSE(
+@@ -952,7 +952,8 @@ AC_RUN_IFELSE(
                FILE *f = fopen(".", "r");
                return f != NULL;]])],
        [ac_cv_fread_reads_directories=no],
@@ -10,7 +10,7 @@
  ])
  if test $ac_cv_fread_reads_directories = yes; then
        FREAD_READS_DIRECTORIES=UnfortunatelyYes
-@@ -963,7 +964,8 @@ AC_RUN_IFELSE(
+@@ -986,7 +987,8 @@ AC_RUN_IFELSE(
                  if (snprintf(buf, 3, "%s", "12345") != 5
                      || strcmp(buf, "12")) return 1]])],
        [ac_cv_snprintf_returns_bogus=no],
@@ -20,7 +20,7 @@
  ])
  if test $ac_cv_snprintf_returns_bogus = yes; then
        SNPRINTF_RETURNS_BOGUS=UnfortunatelyYes
-@@ -986,7 +988,8 @@ yippeeyeswehaveit
+@@ -1009,7 +1011,8 @@ yippeeyeswehaveit
  #endif
  ]),
        [ac_cv_sane_mode_bits=yes],
index 75268a48fc45a6610348685c4b5c5e25c7c903c5..c13336ef000880731564058186eda352f90c4208 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -1312,7 +1312,7 @@ else
+@@ -1365,7 +1365,7 @@ endif
        endif
        curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
        ifeq "$(curl_check)" "072200"
index e3a9ad831c2d5aeac0e2ce0379cc8f36b67e6809..20a5a2a0beb3e39a1780c481c9f0d83c96b02abe 100644 (file)
@@ -12,11 +12,9 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
  imap-send.c | 2 ++
  1 file changed, 2 insertions(+)
 
-diff --git a/imap-send.c b/imap-send.c
-index b4eb886e2..877a4e368 100644
 --- a/imap-send.c
 +++ b/imap-send.c
-@@ -284,8 +284,10 @@ static int ssl_socket_connect(struct imap_socket *sock, int use_tls_only, int ve
+@@ -284,8 +284,10 @@ static int ssl_socket_connect(struct ima
        int ret;
        X509 *cert;
  
@@ -27,6 +25,3 @@ index b4eb886e2..877a4e368 100644
  
        meth = SSLv23_method();
        if (!meth) {
--- 
-2.20.1
-