danish: Remove package
authorJeffery To <jeffery.to@gmail.com>
Mon, 30 Mar 2020 19:44:22 +0000 (03:44 +0800)
committerJeffery To <jeffery.to@gmail.com>
Tue, 31 Mar 2020 06:54:23 +0000 (14:54 +0800)
This version of danish will cease to function once Python 2 is removed
from the feed. The maintainer has indicated[1] that this package will
not be updated to use Python 3.

This package will be added to the abandoned packages feed.

[1]: https://github.com/openwrt/packages/issues/8893#issuecomment-489312682

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
net/danish/Makefile [deleted file]

diff --git a/net/danish/Makefile b/net/danish/Makefile
deleted file mode 100644 (file)
index afaa02a..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-#
-# Copyright (C) 2017 Andrew McConachie
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=danish
-PKG_VERSION:=0.1
-PKG_RELEASE:=2
-PKG_MAINTAINER:=Andrew McConachie <andrew@depht.com>
-PKG_LICENSE:=GPL-3.0
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/smutt/danish.git
-PKG_SOURCE_VERSION:=f726656a4e37c46c037f61334ac48b35b7de25be
-PKG_MIRROR_HASH:=cb0b4bb7a210091d807ee8e4a2876865f32a9bf195836eb2e1edf6c5975d1130
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-include ../../lang/python/python-package.mk
-
-define Package/danish
-       SECTION:=net
-       CATEGORY:=Network
-       SUBMENU:=IP Addresses and Names
-       TITLE:=A middle box implementation of RFC 6698 for HTTPS.
-       URL:=https://github.com/smutt/danish
-       DEPENDS:=+python +python-dns +python-pcapy +python-dpkt +kmod-ipt-filter +iptables-mod-filter
-endef
-
-define Package/danish/description
-  Danish is an experiment in middle-box DANE (RFC 6698) for HTTPS.
-  https://www.middlebox-dane.org/
-endef
-
-define Build/Compile
-       $(call Build/Compile/PyMod,,\
-               install --prefix=/usr --root="$(PKG_INSTALL_DIR)", \
-       )
-endef
-
-define Package/danish/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/danish.py $(1)/usr/sbin/danish
-       $(INSTALL_DIR) $(1)/etc/config
-       $(CP) $(PKG_BUILD_DIR)/danish.conf $(1)/etc/config/danish 
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(CP) $(PKG_BUILD_DIR)/danish.init $(1)/etc/init.d/danish
-endef
-
-$(eval $(call BuildPackage,danish))