strace: add option to enable libdw stack tracing
authorStijn Tintel <stijn@linux-ipv6.be>
Tue, 2 Oct 2018 16:55:11 +0000 (19:55 +0300)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:48:01 +0000 (17:48 +0100)
Fixes build with CONFIG_libdw=y.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
(backported from 7378ca79b9ecc30ddfbe6d965707f1e4f5ebf792)

package/devel/strace/Makefile

index ded6d3bb843c96b777f83232649f25dbedd9094a..b1e27f22c3d3c9bd545508318598be39573a224b 100644 (file)
@@ -54,12 +54,18 @@ system calls a program makes while it is running.
 endef
 
 define Package/strace/config
+config PACKAGE_strace_libdw
+       bool "Enable stack tracing support using libdw"
+       default n
 config PACKAGE_strace_libunwind
        bool "Enable stack tracing support using libunwind (experimental)"
        default n
 endef
 
-CONFIGURE_ARGS += --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
+CONFIGURE_ARGS += \
+       --with-libdw=$(if $(CONFIG_PACKAGE_strace_libdw),yes,no) \
+       --with-libunwind=$(if $(CONFIG_PACKAGE_strace_libunwind),yes,no)
+
 MAKE_FLAGS := \
        CCOPT="$(TARGET_CFLAGS)"