tailscale: fix -version
authorMichal Vasilek <michal.vasilek@nic.cz>
Wed, 12 Oct 2022 17:29:55 +0000 (19:29 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Tue, 18 Oct 2022 07:05:00 +0000 (09:05 +0200)
tailscale version, tailscaled -version and the web UI reported the wrong
version number which doesn't cause any issues, but it can be confusing.

This is fixed by specifying the version in go ldflags similar to how
it's done in many other go packages and the official tailscale Dockerfile.

version.Long version can not be specified in GO_PKG_LDFLAGS_X because it
contains a space and GO_PKG_LDFLAGS_X is always split at a space.

Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
(cherry picked from commit 738f44be4f39191aa4640086f37ef62420442e06)

net/tailscale/Makefile

index c67d4b575dd85576d8dddc16a555dfd8ab48f203..4496c11fe2aff2be8f4da2f1d4610fcedeb6853e 100644 (file)
@@ -27,6 +27,8 @@ PKG_USE_MIPS16:=0
 GO_PKG:=\
        tailscale.com/cmd/tailscale \
        tailscale.com/cmd/tailscaled
+GO_PKG_LDFLAGS:=-X 'tailscale.com/version.Long=$(PKG_VERSION)-$(PKG_RELEASE) (OpenWrt)'
+GO_PKG_LDFLAGS_X:=tailscale.com/version.Short=$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 include ../../lang/golang/golang-package.mk