qualcommax: ipq807x: define configuration for Linksys MX4x00 devices
authorPaweł Owoc <frut3k7@gmail.com>
Sat, 27 Jul 2024 21:25:14 +0000 (23:25 +0200)
committerRobert Marko <robimarko@gmail.com>
Tue, 31 Dec 2024 16:44:10 +0000 (17:44 +0100)
Define shared configuration for Linksys MX4x00 devices.

Signed-off-by: Paweł Owoc <frut3k7@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16070
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/qualcommax/image/ipq807x.mk

index 4a194c6cb7bad6c6f0fe9363f4cd6fc716c362b2..8dacb054a8137bc78d9ce8f52f34326573d30e46 100644 (file)
@@ -170,12 +170,17 @@ define Device/linksys_mx
        DEVICE_PACKAGES := kmod-leds-pca963x
 endef
 
-define Device/linksys_mx4200v1
+define Device/linksys_mx4x00
        $(call Device/linksys_mx)
+       SOC := ipq8174
+       DEVICE_PACKAGES += ipq-wifi-linksys_mx4200
+endef
+
+define Device/linksys_mx4200v1
+       $(call Device/linksys_mx4x00)
        DEVICE_MODEL := MX4200
        DEVICE_VARIANT := v1
-       SOC := ipq8174
-       DEVICE_PACKAGES += ipq-wifi-linksys_mx4200 kmod-bluetooth
+       DEVICE_PACKAGES += kmod-bluetooth
 endef
 TARGET_DEVICES += linksys_mx4200v1