lua-curl-v3: fix build on macos
authorSergey V. Lobanov <sergey@lobanov.in>
Fri, 7 Jan 2022 23:10:02 +0000 (02:10 +0300)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Sat, 8 Jan 2022 07:04:50 +0000 (08:04 +0100)
lua-curl-v3 detects OS and changes compilation flags depends on OS.
If Darwin is detected then it adds GCC non-compatible flags.
OpenWrt is always Linux, OS detection is disabled via UNAME=Linux
as a part of MAKE_FLAGS

Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
lang/lua-curl-v3/Makefile

index 5855b61a45d30182ed65482ceaf3aabe0c2ab16f..08397752132b7b03b1b83f3249eed7aeac330916 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lua-curl-v3
 PKG_VERSION:=0.3.13-snapshot
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
 
@@ -29,6 +29,9 @@ define Package/lua-curl-v3
     MAINTAINER:=Rainer Poisel <rainer.poisel@gmail.com>
 endef
 
+MAKE_FLAGS += \
+       UNAME="Linux"
+
 define Package/lua-curl-v3/description
        Lua bindings to libcurl (Lua-cURLv3)
 endef