atlas-sw-probe: add more binaries
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Wed, 18 Jan 2023 06:57:20 +0000 (07:57 +0100)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Sat, 21 Jan 2023 19:47:58 +0000 (20:47 +0100)
They were added in these commits [1] [2] and if they are not included,
the RIPE Atlas SW Probe does not work correctly.

This should also prevent this from happening in the future as it now. We include all
files with .sh extension file type.

[1] https://github.com/RIPE-NCC/ripe-atlas-software-probe/commit/70ced29fc3217dd8d61e2b78506b6103ded100aa
[2] https://github.com/RIPE-NCC/ripe-atlas-software-probe/commit/71a4ff0e68c55464f766ddb9f1dfe21b22e530db

Fixes: https://github.com/openwrt/packages/issues/20338
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
(cherry picked from commit 1a368a54095d67ea2efb25b7a205999650793bee)

net/atlas-sw-probe/Makefile

index 51b0256bc34857e97652f834b177a907de8e1150..21506dba25418f7cad0fc55c1ba152979425d056 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=atlas-sw-probe
 PKG_VERSION:=5080
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/RIPE-NCC/ripe-atlas-software-probe.git
@@ -90,7 +90,8 @@ define Package/atlas-sw-probe/install
        echo "prod" > $(1)/$(SCRIPTS_DIR)/state/mode
 
        # Copy scripts
-       $(CP) $(PKG_BUILD_DIR)/bin/{ATLAS,common-pre.sh,common.sh,reginit.sh,resolvconf} $(1)/$(SCRIPTS_DIR)/bin/
+       $(CP) $(PKG_BUILD_DIR)/bin/{ATLAS,resolvconf} $(1)/$(SCRIPTS_DIR)/bin/
+       $(CP) $(PKG_BUILD_DIR)/bin/*.sh $(1)/$(SCRIPTS_DIR)/bin/
        $(CP) $(PKG_BUILD_DIR)/bin/arch/{linux,openwrt-sw-probe} $(1)/$(SCRIPTS_DIR)/bin/arch/
 
        # Create config info