lcd4linux: fix compilation with GCC 10
authorRosen Penev <rosenp@gmail.com>
Mon, 10 Aug 2020 07:05:45 +0000 (00:05 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 10 Aug 2020 22:34:28 +0000 (15:34 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/lcd4linux/Makefile
utils/lcd4linux/patches/171-allow-to-specify-drv_generic_graphic_real_clear.patch

index b353bc14ea05f40b8b831165abebe264bbde6d3f..f410994a2111135fde78134bd9b3613fdcbe3b8a 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lcd4linux
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/feckert/lcd4linux
index 5a2664307aca3b703706df871baebd0caba75f1e..109f11e0b731b1b337fedab1ed815dab20e3c18a 100644 (file)
@@ -38,7 +38,7 @@
  extern void (*drv_generic_graphic_real_blit) (const int row, const int col, const int height, const int width);
  
 +/* these functions can be implemented by the real driver */
-+void (*drv_generic_graphic_real_clear) (const RGBA rgba);
++extern void (*drv_generic_graphic_real_clear) (const RGBA rgba);
 +
  /* helper function to get pixel color or gray value */
  extern RGBA drv_generic_graphic_rgb(const int row, const int col);