ddns-scripts: update hotplug installation
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 16 Sep 2020 14:13:04 +0000 (16:13 +0200)
committerFlorian Eckert <fe@dev.tdt.de>
Mon, 21 Sep 2020 08:17:01 +0000 (10:17 +0200)
Signed-off-by: Florian Eckert <fe@dev.tdt.de>
net/ddns-scripts/Makefile
net/ddns-scripts/files/ddns.hotplug [deleted file]
net/ddns-scripts/files/etc/hotplug.d/iface/ddns [new file with mode: 0644]

index 321930f06711e735274210e357e61dd584130b77..6524518aa026efa6ec058201a233145fc065abb5 100755 (executable)
@@ -165,7 +165,7 @@ endef
 
 define Package/ddns-scripts/install
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_BIN) ./files/ddns.hotplug \
+       $(INSTALL_DATA) ./files/etc/hotplug.d/iface/ddns \
                $(1)/etc/hotplug.d/iface/95-ddns
 
        $(INSTALL_DIR) $(1)/etc/init.d
diff --git a/net/ddns-scripts/files/ddns.hotplug b/net/ddns-scripts/files/ddns.hotplug
deleted file mode 100755 (executable)
index 9ef172d..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-# there are other ACTIONs like ifupdate we don't need
-case "$ACTION" in
-       ifup)                                   # OpenWrt is giving a network not phys. Interface
-               /etc/init.d/ddns enabled && /usr/lib/ddns/dynamic_dns_updater.sh -n "$INTERFACE" -- start
-               ;;
-       ifdown)
-               /usr/lib/ddns/dynamic_dns_updater.sh -n "$INTERFACE" -- stop
-               ;;
-esac
diff --git a/net/ddns-scripts/files/etc/hotplug.d/iface/ddns b/net/ddns-scripts/files/etc/hotplug.d/iface/ddns
new file mode 100644 (file)
index 0000000..9ef172d
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+# there are other ACTIONs like ifupdate we don't need
+case "$ACTION" in
+       ifup)                                   # OpenWrt is giving a network not phys. Interface
+               /etc/init.d/ddns enabled && /usr/lib/ddns/dynamic_dns_updater.sh -n "$INTERFACE" -- start
+               ;;
+       ifdown)
+               /usr/lib/ddns/dynamic_dns_updater.sh -n "$INTERFACE" -- stop
+               ;;
+esac