oor: fix compilation with GCC 10
authorRosen Penev <rosenp@gmail.com>
Sun, 19 Jul 2020 07:01:39 +0000 (00:01 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 10 Aug 2020 23:19:11 +0000 (16:19 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/oor/Makefile
net/oor/patches/010-gcc10.patch [new file with mode: 0644]

index 581c6e66f08a35a50697759ba4c7bc964129f697..aac5cd230a739eef0060c0bff52a3dc36c1e015e 100644 (file)
@@ -17,8 +17,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oor
 PKG_VERSION:=1.3.0
-PKG_RELEASE:=2
-
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL=https://github.com/OpenOverlayRouter/oor/releases/download/$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -58,4 +57,4 @@ define Package/oor/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/openWRT/openwrt.init.script $(1)/etc/init.d/oor
 endef
 
-$(eval $(call BuildPackage,oor))
\ No newline at end of file
+$(eval $(call BuildPackage,oor))
diff --git a/net/oor/patches/010-gcc10.patch b/net/oor/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..17242aa
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/oor/data-plane/tun/tun.c
++++ b/oor/data-plane/tun/tun.c
+@@ -53,6 +53,8 @@ int tun_rm_fwd_from_entry(lisp_addr_t *eid_prefix, uint8_t is_local);
+ tun_dplane_data_t * tun_dplane_data_new_init(oor_encap_t encap_type, glist_t *allowed_dst_eids);
+ void tun_dplane_data_free(tun_dplane_data_t *data);
++int tun_receive_fd;
++int tun_ifindex;
+ data_plane_struct_t dplane_tun = {
+         .datap_init = tun_configure_data_plane,
+--- a/oor/data-plane/tun/tun.h
++++ b/oor/data-plane/tun/tun.h
+@@ -60,9 +60,9 @@
+ /* Tun MN variables */
+-int tun_receive_fd;
+-int tun_ifindex;
+-uint8_t *tun_receive_buf;
++extern int tun_receive_fd;
++extern int tun_ifindex;
++extern uint8_t *tun_receive_buf;
+ lisp_addr_t * tun_get_default_output_address(int afi);
+ int tun_get_default_output_socket(int);