newt: Update to 0.52.21
authorJeffery To <jeffery.to@gmail.com>
Sun, 2 Jun 2019 18:37:39 +0000 (02:37 +0800)
committerJeffery To <jeffery.to@gmail.com>
Sun, 2 Jun 2019 20:59:36 +0000 (04:59 +0800)
This also removes $(FPIC) from TARGET_CFLAGS.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
libs/newt/Makefile
libs/newt/patches/001-pythonvers.patch [deleted file]

index e30f77a6b16b37533526cdb2761c579c70acd1c0..462d35dfc4bb3774b86306fb5668730060855d00 100644 (file)
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=newt
-PKG_VERSION:=0.52.20
-PKG_RELEASE:=2
+PKG_VERSION:=0.52.21
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://releases.pagure.org/newt
-PKG_HASH:=8d66ba6beffc3f786d4ccfee9d2b43d93484680ef8db9397a4fb70b5adbb6dbc
+PKG_HASH:=265eb46b55d7eaeb887fca7a1d51fe115658882dfe148164b6c49fccac5abb31
 
 PKG_LICENSE:=LGPL-2.0
 PKG_LICENSE_FILES:=COPYING
@@ -82,17 +82,13 @@ $(call Package/newt/Default/description)
   This is the Newt module for Python 3.
 endef
 
-TARGET_CFLAGS+= $(FPIC)
-
 CONFIGURE_ARGS+= \
        --enable-largefile \
-       --with-python \
+       --with-python=python$(PYTHON3_VERSION) \
        --without-tcl \
        --without-gpm-support \
        --with-colorsfile=/etc/newt/palette
 
-CONFIGURE_VARS+= PYTHONVERS="python$(PYTHON3_VERSION)"
-
 MAKE_VARS+= PYTHON_CONFIG_PATH="$(STAGING_DIR)/usr/bin"
 
 Build/Compile=$(call Build/Compile/Default,)
diff --git a/libs/newt/patches/001-pythonvers.patch b/libs/newt/patches/001-pythonvers.patch
deleted file mode 100644 (file)
index d0ff5d7..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -3957,7 +3957,6 @@ if test "x$with_python" = "xno"; then
- $as_echo "skipped" >&6; }
-   PYTHONVERS=
- else
--  PYTHONVERS=$(ls /usr/include/python*/Python.h 2> /dev/null | sed 's|.*\(python[0-9]*\.[0-9]*\).*|\1|g' | tr '\n' ' ')
-   { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYTHONVERS" >&5
- $as_echo "$PYTHONVERS" >&6; }
- fi