sunxi: t113: add an extra step to copy u-boot into bin/ for eMMC boot support
authorZoltan HERPAI <wigyori@uid0.hu>
Sat, 26 Aug 2023 23:43:32 +0000 (01:43 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Mon, 29 Apr 2024 07:55:14 +0000 (09:55 +0200)
Put an u-boot.bin into bin/ to make it easier for picking it to
install onto mmcblk1boot0.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/sunxi/image/Makefile
target/linux/sunxi/image/cortexa7.mk

index 283a7b973ce7d1c51c515c51a5203bdc78a10aa5..8acc19f5ba8726dfeb5e34e4f383e898ce50b378 100644 (file)
@@ -48,6 +48,10 @@ define Build/sunxi-emmc
        rm -f $@.boot
 endef
 
+define Build/sunxi-emmc-uboot-copy
+       $(CP) $(STAGING_DIR_IMAGE)/$(DEVICE_NAME)-u-boot-with-spl.bin $(BIN_DIR)/
+endef
+
 define Device/Default
   PROFILES := Default
   KERNEL_NAME := zImage
index 91e0cf580f5f67ed4ac05dd191f34f5fdd548337..66f233f766cd31736937a7e56b40f1e3eaddca70 100644 (file)
@@ -268,7 +268,7 @@ define Device/myir_myd-yt113x
   SOC := sun8i-t113s
   IMAGES += emmc.img.gz
   IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
-  IMAGE/emmc.img.gz := boot-scr-emmc | sunxi-emmc | append-metadata | gzip
+  IMAGE/emmc.img.gz := sunxi-emmc-uboot-copy | boot-scr-emmc | sunxi-emmc | append-metadata | gzip
 endef
 TARGET_DEVICES += myir_myd-yt113x