projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7be93d7
)
package/kernel: do not build kmod-usb-storage-extras on targets which have them built-in
author
Nicolas Thill
<nico@openwrt.org>
Fri, 25 Nov 2011 12:19:14 +0000
(12:19 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Fri, 25 Nov 2011 12:19:14 +0000
(12:19 +0000)
SVN-Revision: 29335
package/kernel/modules/usb.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/usb.mk
b/package/kernel/modules/usb.mk
index 437a199bf49e3542ce16ffd37e0a52268d0385f9..3d18c0fe441586068c20fd678d1115fd7e570888 100644
(file)
--- a/
package/kernel/modules/usb.mk
+++ b/
package/kernel/modules/usb.mk
@@
-518,7
+518,8
@@
$(eval $(call KernelPackage,usb-storage))
define KernelPackage/usb-storage-extras
SUBMENU:=$(USB_MENU)
TITLE:=Extra drivers for usb-storage
- DEPENDS:=@LINUX_2_6 +kmod-usb-storage
+ DEPENDS:=@LINUX_2_6 +kmod-usb-storage \
+ @!(TARGET_ixp4xx_harddisk||TARGET_orion_harddisk||TARGET_x86_olpc)
KCONFIG:= \
CONFIG_USB_STORAGE_ALAUDA \
CONFIG_USB_STORAGE_CYPRESS_ATACB \