kasan: Makefile: Replace -pg with CC_FLAGS_FTRACE
authorTorsten Duwe <duwe@lst.de>
Fri, 8 Feb 2019 15:10:14 +0000 (16:10 +0100)
committerWill Deacon <will.deacon@arm.com>
Tue, 9 Apr 2019 09:34:59 +0000 (10:34 +0100)
In preparation for arm64 supporting ftrace built on other compiler
options, let's have Makefiles remove the $(CC_FLAGS_FTRACE) flags,
whatever these may be, rather than assuming '-pg'.

There should be no functional change as a result of this patch.

Reviewed-by: Mark Rutland <mark.rutland@arm.com>
Acked-by: Andrey Ryabinin <aryabinin@virtuozzo.com>
Signed-off-by: Torsten Duwe <duwe@suse.de>
Signed-off-by: Will Deacon <will.deacon@arm.com>
mm/kasan/Makefile

index 5d1065efbd4769151a5ea5f3540f94d2dad7b63c..f06ee820d35602a54270a3a12677a2c15be1f16b 100644 (file)
@@ -5,9 +5,9 @@ UBSAN_SANITIZE_generic.o := n
 UBSAN_SANITIZE_tags.o := n
 KCOV_INSTRUMENT := n
 
-CFLAGS_REMOVE_common.o = -pg
-CFLAGS_REMOVE_generic.o = -pg
-CFLAGS_REMOVE_tags.o = -pg
+CFLAGS_REMOVE_common.o = $(CC_FLAGS_FTRACE)
+CFLAGS_REMOVE_generic.o = $(CC_FLAGS_FTRACE)
+CFLAGS_REMOVE_tags.o = $(CC_FLAGS_FTRACE)
 
 # Function splitter causes unnecessary splits in __asan_load1/__asan_store1
 # see: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63533