projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e0a5696
)
selftests: watchdog: fix to use TEST_GEN_PROGS and remove clean
author
Shuah Khan
<shuahkh@osg.samsung.com>
Fri, 8 Sep 2017 22:05:50 +0000
(16:05 -0600)
committer
Shuah Khan
<shuahkh@osg.samsung.com>
Thu, 21 Sep 2017 13:55:38 +0000
(07:55 -0600)
TEST_PROGS should be used for test scripts that don't ned to be built.
Use TEST_GEN_PROGS instead which is intended for test executables.
Remove clean target and let the common clean take care of cleaning.
Signed-off-by: Shuah Khan <shuahkh@osg.samsung.com>
tools/testing/selftests/watchdog/Makefile
patch
|
blob
|
history
diff --git
a/tools/testing/selftests/watchdog/Makefile
b/tools/testing/selftests/watchdog/Makefile
index f863c664e3d143be1dd439a6098d5e389a49e762..ee068511fd0bc68ba8cb8b54bbe8a5c9371c322e 100644
(file)
--- a/
tools/testing/selftests/watchdog/Makefile
+++ b/
tools/testing/selftests/watchdog/Makefile
@@
-1,8
+1,3
@@
-TEST_PROGS := watchdog-test
-
-all: $(TEST_PROGS)
+TEST_GEN_PROGS := watchdog-test
include ../lib.mk
-
-clean:
- rm -fr $(TEST_PROGS)