django-restframework: fix by splitting variants
authorPeter Stadler <peter.stadler@student.uibk.ac.at>
Fri, 31 Jan 2020 07:29:20 +0000 (08:29 +0100)
committerPeter Stadler <peter.stadler@student.uibk.ac.at>
Fri, 31 Jan 2020 07:34:17 +0000 (08:34 +0100)
Split python2 and python3 packages and update to newest versions:
  * python-django-restframework version 3.9.4 using django1
  * python3-django-restframework version 3.11.0 using django3
This fixes the issue that the restframework cannot import name
'python_2_unicode_compatible' from 'django.utils.encoding', when
using version 3.9.x together with Django 3.y.

Signed-off-by: Peter Stadler <peter.stadler@student.uibk.ac.at>
lang/python/django-restframework/Makefile
lang/python/django1-restframework/Makefile [new file with mode: 0644]

index 9bff50d15bdbad4c69b9181d1c8037fc187f3ff8..f9fdbd33106685d2e87a614cf9b25b5cdb4027f8 100644 (file)
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=django-restframework
-PKG_VERSION:=3.9.0
-PKG_RELEASE:=5
+PKG_VERSION:=3.11.0
+PKG_RELEASE:=1
 
 PYPI_NAME:=djangorestframework
-PKG_HASH:=607865b0bb1598b153793892101d881466bd5a991de12bd6229abb18b1c86136
+PKG_HASH:=e782087823c47a26826ee5b6fa0c542968219263fb3976ec3c31edab23a4001f
 
 PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
 PKG_LICENSE:=BSD-3-Clause
@@ -20,49 +20,25 @@ PKG_LICENSE_FILES:=LICENSE.md
 
 include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
-include ../python-package.mk
 include ../python3-package.mk
 
-define Package/django-restframework/Default
+define Package/python3-django-restframework
   SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=Web APIs for Django, made easy.
   URL:=https://www.django-rest-framework.org
-endef
-
-define Package/python-django-restframework
-$(call Package/django-restframework/Default)
-  DEPENDS:= \
-       +PACKAGE_python-django-restframework:python \
-       python-django1
-  VARIANT:=python
-  MDEPENDS:=python-django1
-endef
-
-define Package/python-django-restframework/description
-  Web APIs for Django, made easy.
-endef
-
-define Package/python3-django-restframework
-$(call Package/django-restframework/Default)
-  DEPENDS:= \
-       +PACKAGE_python3-django-restframework:python3 \
-       python3-django
+  DEPENDS:=+python3 python3-django
   VARIANT:=python3
   MDEPENDS:=python3-django
 endef
 
 define Package/python3-django-restframework/description
-$(call Package/python-django-restframework/description)
+  Web APIs for Django, made easy.
 .
 (Variant for Python3)
 endef
 
-$(eval $(call PyPackage,python-django-restframework))
-$(eval $(call BuildPackage,python-django-restframework))
-$(eval $(call BuildPackage,python-django-restframework-src))
-
 $(eval $(call Py3Package,python3-django-restframework))
 $(eval $(call BuildPackage,python3-django-restframework))
 $(eval $(call BuildPackage,python3-django-restframework-src))
diff --git a/lang/python/django1-restframework/Makefile b/lang/python/django1-restframework/Makefile
new file mode 100644 (file)
index 0000000..040e531
--- /dev/null
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2007-2017 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=django1-restframework
+PKG_VERSION:=3.9.4
+PKG_RELEASE:=1
+
+PYPI_NAME:=djangorestframework
+PKG_HASH:=c12869cfd83c33d579b17b3cb28a2ae7322a53c3ce85580c2a2ebe4e3f56c4fb
+
+PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE.md
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python-package.mk
+
+define Package/python-django-restframework
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Web APIs for Django, made easy.
+  URL:=https://www.django-rest-framework.org
+  DEPENDS:=+python python-django1
+  VARIANT:=python
+  MDEPENDS:=python-django1
+endef
+
+define Package/python-django-restframework/description
+  Web APIs for Django, made easy.
+endef
+
+$(eval $(call PyPackage,python-django-restframework))
+$(eval $(call BuildPackage,python-django-restframework))
+$(eval $(call BuildPackage,python-django-restframework-src))