forked-daapd: fix compilation with newer musl
authorRosen Penev <rosenp@gmail.com>
Mon, 30 Mar 2020 04:26:24 +0000 (21:26 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 30 Mar 2020 04:28:37 +0000 (21:28 -0700)
Needed for errno definition.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
sound/forked-daapd/Makefile
sound/forked-daapd/patches/010-errno.patch [new file with mode: 0644]

index 9dc7aad302b7cb9d969401082afc06bd838a1b18..8e911f910460109da1b3d99f654eb6daa018c65f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=forked-daapd
 PKG_VERSION:=27.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/ejurgensen/$(PKG_NAME)/releases/download/$(PKG_VERSION)/
diff --git a/sound/forked-daapd/patches/010-errno.patch b/sound/forked-daapd/patches/010-errno.patch
new file mode 100644 (file)
index 0000000..b7fee52
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/src/websocket.c
++++ b/src/websocket.c
+@@ -25,6 +25,7 @@
+ #ifdef HAVE_PTHREAD_NP_H
+ # include <pthread_np.h>
+ #endif
++#include <errno.h>
+ #include <stdbool.h>
+ #include <stdio.h>
+ #include <string.h>