unzip: fix cross-compilation and skip target checks
authorSteven Barth <steven@midlink.org>
Sat, 14 Jun 2014 18:12:56 +0000 (20:12 +0200)
committerSteven Barth <steven@midlink.org>
Sat, 14 Jun 2014 18:13:49 +0000 (20:13 +0200)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Signed-off-by: Steven Barth <steven@midlink.org>
utils/unzip/Makefile

index 1628d0406f7c0d7e259698065a4ef9bbeb38e7c9..441b4835ef452c7a76dffbb4daf8b9d6ea0d9ea5 100644 (file)
@@ -43,12 +43,15 @@ endef
 define Build/Configure
 endef
 
+TARGET_CFLAGS += -DNO_LCHMOD -DLARGE_FILE_SUPPORT
+
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile generic \
+       $(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile unzips \
                $(TARGET_CONFIGURE_OPTS) \
                prefix="$(PKG_INSTALL_DIR)/usr" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CF="$(TARGET_CFLAGS) -O $(TARGET_CPPFLAGS) -I. -DUNIX" \
+               CC="$(TARGET_CC)" \
                LD="$(TARGET_CC) $(TARGET_LDFLAGS)" \
                install
 endef