zerotier: add patch to avoid including sys/auxv.h
authorRosen Penev <rosenp@gmail.com>
Mon, 7 Dec 2020 07:53:45 +0000 (23:53 -0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 7 Dec 2020 07:55:20 +0000 (23:55 -0800)
It seems it's not needed and not supported under uClibc-ng.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/zerotier/Makefile
net/zerotier/patches/0001-find-miniupnpc.h-in-staging-directory.patch
net/zerotier/patches/0002-remove-pie.patch
net/zerotier/patches/0003-remove-arm32-conservative-CFLAGS.patch
net/zerotier/patches/0004-accept-external-linker-flags.patch
net/zerotier/patches/0005-link-natpmp.patch
net/zerotier/patches/0006-gcc10.patch
net/zerotier/patches/0007-add-cerrno-header-for-str-errno.patch
net/zerotier/patches/0008-fix-compilation-for-arm_cortex-a7-neon.patch
net/zerotier/patches/010-auxv.patch [new file with mode: 0644]

index fb854adcd4d07000b19f09308feff79903d769f1..f3e0cf9c6c45b96a7bec9d393eeaa9fd7ed95e99 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zerotier
 PKG_VERSION:=1.6.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?
index 995e0c3627b26a77779771d5d71c4e3a6fd9e64f..e9724f01d2f6e35b00e6cbcdd990622e2f2f9b52 100644 (file)
@@ -7,8 +7,6 @@ Subject: [PATCH 1/8] find miniupnpc.h in staging directory
  make-linux.mk | 4 ++--
  1 file changed, 2 insertions(+), 2 deletions(-)
 
-diff --git a/make-linux.mk b/make-linux.mk
-index 03cce517..cae8459a 100644
 --- a/make-linux.mk
 +++ b/make-linux.mk
 @@ -25,8 +25,8 @@ TIMESTAMP=$(shell date +"%Y%m%d%H%M")
@@ -22,6 +20,3 @@ index 03cce517..cae8459a 100644
  ifeq ($(MINIUPNPC_IS_NEW_ENOUGH),1)
        override DEFS+=-DZT_USE_SYSTEM_MINIUPNPC
        LDLIBS+=-lminiupnpc
--- 
-2.29.2
-
index 6032104d28b930ba6e3eba99fa555499eb50994f..aa297f85d422808d950822d11bf4a882885a3384 100644 (file)
@@ -9,8 +9,6 @@ when making a shared object; recompile with -fPIC" error
  make-linux.mk | 6 +++---
  1 file changed, 3 insertions(+), 3 deletions(-)
 
-diff --git a/make-linux.mk b/make-linux.mk
-index cae8459a..bd05e6b5 100644
 --- a/make-linux.mk
 +++ b/make-linux.mk
 @@ -73,11 +73,11 @@ ifeq ($(ZT_DEBUG),1)
@@ -28,6 +26,3 @@ index cae8459a..bd05e6b5 100644
        STRIP?=strip
        STRIP+=--strip-all
  endif
--- 
-2.29.2
-
index 3da18f30a0db50d70d05f49fd7df32790c4177ff..f0ffacf0e70158d03e60e4a41535726889ce4e41 100644 (file)
@@ -7,8 +7,6 @@ Subject: [PATCH 3/8] remove arm32 conservative CFLAGS
  make-linux.mk | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/make-linux.mk b/make-linux.mk
-index bd05e6b5..b1bb638e 100644
 --- a/make-linux.mk
 +++ b/make-linux.mk
 @@ -276,7 +276,7 @@ ifeq ($(ZT_CONTROLLER),1)
@@ -20,6 +18,3 @@ index bd05e6b5..b1bb638e 100644
        ifeq ($(shell if [ -e /usr/bin/dpkg ]; then dpkg --print-architecture; fi),armel)
                override CFLAGS+=-march=armv5t -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
                override CXXFLAGS+=-march=armv5t -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
--- 
-2.29.2
-
index 76d1a4153d67670e28ebe682b5d29d2003ab6609..de144d25c70049b607bd0215c837f16dcda0a06f 100644 (file)
@@ -7,8 +7,6 @@ Subject: [PATCH 4/8] accept external linker flags
  make-linux.mk | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/make-linux.mk b/make-linux.mk
-index b1bb638e..d358ecfb 100644
 --- a/make-linux.mk
 +++ b/make-linux.mk
 @@ -77,7 +77,7 @@ else
@@ -20,6 +18,3 @@ index b1bb638e..d358ecfb 100644
        STRIP?=strip
        STRIP+=--strip-all
  endif
--- 
-2.29.2
-
index c26f0b3f884260a8f3d2f53ea720da7342123e5e..893c10a05460f52a95e899c6e043fda9133cf734 100644 (file)
@@ -7,8 +7,6 @@ Subject: [PATCH 5/8] link natpmp
  make-linux.mk | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/make-linux.mk b/make-linux.mk
-index d358ecfb..cbee51c3 100644
 --- a/make-linux.mk
 +++ b/make-linux.mk
 @@ -34,7 +34,7 @@ else
@@ -20,6 +18,3 @@ index d358ecfb..cbee51c3 100644
        ONE_OBJS+=ext/libnatpmp/natpmp.o ext/libnatpmp/getgateway.o
  else
        LDLIBS+=-lnatpmp
--- 
-2.29.2
-
index 756ced52601f0214d7fd0b883b7ed4651614000c..9550dfdde47e70d82392c5c244843985bc24086f 100644 (file)
@@ -7,8 +7,6 @@ Subject: [PATCH 6/8] gcc10
  osdep/Binder.hpp | 6 +++---
  1 file changed, 3 insertions(+), 3 deletions(-)
 
-diff --git a/osdep/Binder.hpp b/osdep/Binder.hpp
-index c52f303b..8a38ab04 100644
 --- a/osdep/Binder.hpp
 +++ b/osdep/Binder.hpp
 @@ -396,9 +396,9 @@ public:
@@ -24,6 +22,3 @@ index c52f303b..8a38ab04 100644
                                                phy.setIfName(udps,(char*)ii->second.c_str(),(int)ii->second.length());
                                                ++_bindingCount;
                                        }
--- 
-2.29.2
-
index 15e144cd6aecaf84b66d1f6072e14485407403be..d2595f98b619d90b75246c2b03cc73b35fae4c8b 100644 (file)
@@ -10,8 +10,6 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
  osdep/LinuxNetLink.cpp | 2 ++
  1 file changed, 2 insertions(+)
 
-diff --git a/osdep/LinuxNetLink.cpp b/osdep/LinuxNetLink.cpp
-index 421da1f6..b7c13edf 100644
 --- a/osdep/LinuxNetLink.cpp
 +++ b/osdep/LinuxNetLink.cpp
 @@ -22,6 +22,8 @@
@@ -23,6 +21,3 @@ index 421da1f6..b7c13edf 100644
  #ifndef IFNAMSIZ
  #define IFNAMSIZ 16
  #endif
--- 
-2.29.2
-
index 48a96a62af946c2f6674247c1c5c07d1e5a7c7ef..88b640f704d435d09d1fdd5d5f4593c5a42d06a6 100644 (file)
@@ -10,8 +10,6 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
  node/Constants.hpp | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/node/Constants.hpp b/node/Constants.hpp
-index 400976c1..eccc3a31 100644
 --- a/node/Constants.hpp
 +++ b/node/Constants.hpp
 @@ -109,7 +109,7 @@
@@ -23,6 +21,3 @@ index 400976c1..eccc3a31 100644
  #if (defined(__APPLE__) && !defined(__LP64__)) || (defined(__ANDROID__) && defined(__arm__))
  #ifdef ZT_ARCH_ARM_HAS_NEON
  #undef ZT_ARCH_ARM_HAS_NEON
--- 
-2.29.2
-
diff --git a/net/zerotier/patches/010-auxv.patch b/net/zerotier/patches/010-auxv.patch
new file mode 100644 (file)
index 0000000..3499168
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/node/Utils.cpp
++++ b/node/Utils.cpp
+@@ -28,7 +28,7 @@
+ #include <sys/stat.h>
+ #include <sys/uio.h>
+ #include <dirent.h>
+-#ifdef __LINUX__
++#if 0
+ #include <sys/auxv.h>
+ #endif
+ #endif