ffmpeg: Disable mips32r2 for mips32 CPUs
authorBruno Randolf <br1@einfach.org>
Tue, 14 Oct 2014 09:14:14 +0000 (10:14 +0100)
committerBruno Randolf <br1@einfach.org>
Tue, 14 Oct 2014 09:17:11 +0000 (10:17 +0100)
Some CPUs, such as the au1500 are MIPS32 but not MIPS32r2 and we have to
explicitly disable mips32r2 in the ffmpeg configure script.

Signed-off-by: Bruno Randolf <br1@einfach.org>
multimedia/ffmpeg/Makefile

index f3c047dd40b8334dbf0fe82da05bbb49b040aec3..2470ad25668b36cda6251b73ae0dbd964f1e7d7c 100644 (file)
@@ -399,6 +399,10 @@ FFMPEG_CONFIGURE:= \
        --disable-vdpau \
        --disable-outdevs
 
+ifeq ($(CONFIG_CPU_TYPE),"mips32")
+       FFMPEG_CONFIGURE +=--disable-mips32r2
+endif
+
 ifeq ($(BUILD_VARIANT),custom)
 
   FFMPEG_ENABLE= \