Build ulogd-mod-pcap
authorFlorian Fainelli <florian@openwrt.org>
Wed, 19 Apr 2006 11:09:52 +0000 (11:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 19 Apr 2006 11:09:52 +0000 (11:09 +0000)
SVN-Revision: 3672

openwrt/package/Makefile
openwrt/package/ulogd/Config.in
openwrt/package/ulogd/Makefile
openwrt/package/ulogd/patches/ulogd-1.23-pcap_ldflags.patch [new file with mode: 0644]

index 7596e6287ef6dd8c4364dfaefc3374c1fd9b5073..27aa179f3f4ae9ff36cd7a93f5539ca5fc251451 100644 (file)
@@ -230,6 +230,9 @@ ulogd-compile: iptables-compile
 ifneq ($(BR2_PACKAGE_ULOGD_MYSQL),)
 ulogd-compile: mysql-compile
 endif
+ifneq ($(BR2_PACKAGE_ULOGD_PCAP),)
+ulogd-compile:pcap-compile
+endif
 ifneq ($(BR2_PACKAGE_ULOGD_PGSQL),)
 ulogd-compile: postgresql-compile
 endif
index c3dd0b081f3e94c959b1d57cb3b90509e0ede0f8..0a59ab199cf35696ee11503ec068b4752fda8a93 100644 (file)
@@ -19,6 +19,13 @@ config BR2_PACKAGE_ULOGD_MOD_MYSQL
        depends BR2_PACKAGE_ULOGD
        select BR2_PACKAGE_LIBMYSQLCLIENT
 
+config BR2_PACKAGE_ULOGD_MOD_PCAP
+       prompt"...-mod-pcap - Output plugin for pcap logging format"
+       tristate
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_ULOGD
+       select BR2_PACKAGE_LIBPCAP
+
 config BR2_PACKAGE_ULOGD_MOD_PGSQL
        prompt "...-mod-pgsql - Output plugin for logging into a PostgreSQL database"
        tristate
index d4ac434975da1c061db0f40fbb314697251c2307..ffe08eac06f1846d14818a464a4f2580f73a193f 100644 (file)
@@ -21,6 +21,12 @@ ifneq ($(BR2_PACKAGE_ULOGD_MOD_MYSQL),)
 ULOGD_MYSQL_OPTION:=--with-mysql=$(STAGING_DIR)/usr
 endif
 
+ifneq ($(BR2_PACKAGE_ULOGD_MOD_PCAP),)
+ULOGD_PCAP_HEADER:=yes
+else
+ULOGD_PCAP_HEADER:=no
+endif
+
 ifneq ($(BR2_PACKAGE_ULOGD_MOD_PGSQL),)
 ULOGD_PGSQL_OPTION:=--with-pgsql=$(STAGING_DIR)/usr
 endif
@@ -41,10 +47,12 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,ULOGD,ulogd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ULOGD_MOD_MYSQL,ulogd-mod-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,ULOGD_MOD_PCAP,ulogd-mod-pcap,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ULOGD_MOD_PGSQL,ulogd-mod-pgsql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ULOGD_MOD_EXTRA,ulogd-mod-extra,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(eval $(call IPKG_plugin_template,ULOGD_MOD_MYSQL,MYSQL))
+$(eval $(call IPKG_plugin_template,ULOGD_MOD_PCAP,PCAP))
 $(eval $(call IPKG_plugin_template,ULOGD_MOD_PGSQL,PGSQL))
 $(eval $(call IPKG_plugin_template,ULOGD_MOD_EXTRA,LOCAL LOGEMU OPRINT PWSNIFF SYSLOG))
 
@@ -54,7 +62,7 @@ $(PKG_BUILD_DIR)/.configured:
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_header_pcap_h=no \
+               ac_cv_header_pcap_h=$(ULOGD_PCAP_HEADER) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
@@ -87,6 +95,7 @@ $(PKG_BUILD_DIR)/.built:
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               STAGING_DIR=$(STAGING_DIR) \
                all install
        touch $@
 
diff --git a/openwrt/package/ulogd/patches/ulogd-1.23-pcap_ldflags.patch b/openwrt/package/ulogd/patches/ulogd-1.23-pcap_ldflags.patch
new file mode 100644 (file)
index 0000000..d451823
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN ulogd-1.23/pcap/Makefile.in ulogd-1.23.new/pcap/Makefile.in
+--- ulogd-1.23/pcap/Makefile.in        2004-03-23 23:36:04.000000000 +0100
++++ ulogd-1.23.new/pcap/Makefile.in    2006-04-19 11:30:45.000000000 +0200
+@@ -14,7 +14,7 @@
+ distrib:
+ $(SHARED_LIBS): %.so: %_sh.o
+-      $(LD) -shared -o $@ $< -lc -lpcap
++      $(LD) -shared -o $@ $< -lc -lpcap -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+ %_sh.o: %.c
+       $(CC) $(SH_CFLAGS) -o $@ -c $<