apache: rename bin from httpd to apache2
authorSebastian Kemper <sebastian_ml@gmx.net>
Sun, 26 Jan 2020 18:06:06 +0000 (19:06 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sun, 26 Jan 2020 18:07:03 +0000 (19:07 +0100)
This way there's no need to worry about overwriting another httpd binary
or symlink from another package, for example busyboxes httpd.

The init script is also renamed to apache2 for consistency.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/apache/Makefile
net/apache/files/apache.init [deleted file]
net/apache/files/apache2.init [new file with mode: 0644]

index 81ae2e5e81f25fb97ebd7e1f6939b6db9a1175ed..12094629ca5b1f5432f564ab97c1e6da35fda5fa 100644 (file)
@@ -78,7 +78,7 @@ This package contains the Apache web server and utility programs.
 endef
 
 define Package/apache/conffiles
-/etc/apache2/httpd.conf
+/etc/apache2/apache2.conf
 /etc/apache2/extra/httpd-autoindex.conf
 /etc/apache2/extra/httpd-dav.conf
 /etc/apache2/extra/httpd-default.conf
@@ -93,7 +93,7 @@ define Package/apache/conffiles
 /etc/apache2/extra/proxy-html.conf
 /etc/apache2/magic
 /etc/apache2/mime.types
-/etc/init.d/apache
+/etc/init.d/apache2
 endef
 
 define Package/apache-ab
@@ -198,6 +198,7 @@ CONFIGURE_ARGS+= \
        --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
        --with-mpm=prefork \
        --with-pcre="$(STAGING_DIR)/usr/bin/pcre-config" \
+       --with-program-name=apache2 \
        --with-ssl
 
 ifneq ($(CONFIG_PACKAGE_apache-mod-deflate),)
@@ -297,10 +298,10 @@ define Package/apache/install
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/apache2/extra/* \
                                        $(1)/etc/apache2/extra
        $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/etc/apache2/{httpd.conf,magic,mime.types} \
-                                                       $(1)/etc/apache2
+               $(PKG_INSTALL_DIR)/etc/apache2/{apache2.conf,magic,mime.types} \
+                                                               $(1)/etc/apache2
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/apache.init $(1)/etc/init.d/apache
+       $(INSTALL_BIN) ./files/apache2.init $(1)/etc/init.d/apache2
        $(INSTALL_DIR) $(1)/usr/lib/apache2
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/apache2/*.so \
                                        $(1)/usr/lib/apache2
@@ -316,7 +317,7 @@ define Package/apache/install
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/{dbmmanage,htdbm,htdigest,htpasswd,httxt2dbm,logresolve} \
                                                                                        $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{apachectl,httpd} \
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{apachectl,apache2} \
                                                        $(1)/usr/sbin
 endef
 
diff --git a/net/apache/files/apache.init b/net/apache/files/apache.init
deleted file mode 100644 (file)
index a0136c8..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=99
-
-reload() {
-       apachectl -k restart
-}
-
-restart() {
-       apachectl -k restart
-}
-
-start() {
-       mkdir -p /var/log/apache2 /var/run/apache2
-       apachectl -k start
-}
-
-stop() {
-       apachectl -k stop
-}
diff --git a/net/apache/files/apache2.init b/net/apache/files/apache2.init
new file mode 100644 (file)
index 0000000..a0136c8
--- /dev/null
@@ -0,0 +1,20 @@
+#!/bin/sh /etc/rc.common
+
+START=99
+
+reload() {
+       apachectl -k restart
+}
+
+restart() {
+       apachectl -k restart
+}
+
+start() {
+       mkdir -p /var/log/apache2 /var/run/apache2
+       apachectl -k start
+}
+
+stop() {
+       apachectl -k stop
+}