python-pyrsistent: Update to 0.19.3, update list of dependencies
authorJeffery To <jeffery.to@gmail.com>
Fri, 18 Aug 2023 20:36:38 +0000 (04:36 +0800)
committerTianling Shen <cnsztl@gmail.com>
Mon, 28 Aug 2023 00:52:16 +0000 (08:52 +0800)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
(cherry picked from commit 383b8c1658c5f9e39e17352f857338d0e6b46d16)

lang/python/python-pyrsistent/Makefile

index b9ae85d7eccdd2ddbc2b46c85310702a54b1e438..64d687399c8273b169fffff65d808039f1e65548 100644 (file)
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-pyrsistent
-PKG_VERSION:=0.16.0
+PKG_VERSION:=0.19.3
 PKG_RELEASE:=1
 
 PYPI_NAME:=pyrsistent
-PKG_HASH:=28669905fe725965daa16184933676547c5bb40a5153055a8dee2a4bd7933ad3
+PKG_HASH:=1a2994773706bbb4995c31a97bc94f1418314923bd1048c6d964837040376440
 
 PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
 PKG_LICENSE:=MIT
@@ -28,12 +28,13 @@ define Package/python3-pyrsistent
   CATEGORY:=Languages
   TITLE:=Persistent/Functional/Immutable data structures
   URL:=https://github.com/tobgu/pyrsistent
-  DEPENDS:=+python3-light +python3-six
+  DEPENDS:=+python3-light
 endef
 
 define Package/python3-pyrsistent/description
-  Pyrsistent is a number of persistent collections (by some referred to as functional data structures).
-  Persistent in the sense that they are immutable.
+Pyrsistent is a number of persistent collections (by some referred to as
+functional data structures). Persistent in the sense that they are
+immutable.
 endef
 
 $(eval $(call Py3Package,python3-pyrsistent))