unbound: limit outside script source to init funciton scope
authorEric Luehrsen <ericluehrsen@gmail.com>
Tue, 26 Jun 2018 00:40:21 +0000 (20:40 -0400)
committerEric Luehrsen <ericluehrsen@gmail.com>
Tue, 26 Jun 2018 00:45:35 +0000 (20:45 -0400)
Signed-off-by: Eric Luehrsen <ericluehrsen@gmail.com>
net/unbound/Makefile
net/unbound/files/unbound.init

index 43dea0a2089132cac5ccb8778ca12d588ac7ced3..93856b2bdad729f0dd7b3ca51b2a9434dc58b759 100644 (file)
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=unbound
 PKG_VERSION:=1.7.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
-PKG_MAINTAINER:=Eric Luehrsen <ericluehrsen@hotmail.com>
+PKG_MAINTAINER:=Eric Luehrsen <ericluehrsen@gmail.com>
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.unbound.net/downloads
index ac0dd580653744b878755513b98ee8da6505cdcb..2f93b4d65096d994a9b5b097e55a7505df363dea 100755 (executable)
@@ -16,10 +16,6 @@ PROG=/usr/sbin/unbound
 
 ##############################################################################
 
-. /usr/lib/unbound/unbound.sh
-
-##############################################################################
-
 boot() {
   UNBOUND_BOOT=1
   start "$@"
@@ -34,10 +30,11 @@ start_service() {
   fi
 
   # complex UCI work
+  . /usr/lib/unbound/unbound.sh
   unbound_start
 
   # standard procd clause
-  procd_open_instance
+  procd_open_instance "unbound"
   procd_set_param command $PROG -d -c $UNBOUND_CONFFILE
   procd_set_param respawn
   procd_close_instance
@@ -46,6 +43,8 @@ start_service() {
 ##############################################################################
 
 stop_service() {
+  # clean up
+  . /usr/lib/unbound/unbound.sh
   unbound_stop
 
   # Wait! on restart Unbound may take time writing closure stats to syslog