Corrected ticket #170, thanks for submitting !
authorFlorian Fainelli <florian@openwrt.org>
Mon, 2 Jan 2006 14:15:50 +0000 (14:15 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 2 Jan 2006 14:15:50 +0000 (14:15 +0000)
SVN-Revision: 2809

openwrt/package/iptables/Config.in
openwrt/package/iptables/Makefile
openwrt/package/iptables/ipkg/iptables-mod-imq.control [new file with mode: 0644]

index a32dbfe88ad13f52eca568b58d3f4cc146909783..95199821e2bbf7f568bd2a54506a5e06a36a053d 100644 (file)
@@ -14,6 +14,7 @@ config BR2_PACKAGE_IPTABLES_EXTRA
        select BR2_PACKAGE_IPTABLES_MOD_CONNTRACK
        select BR2_PACKAGE_IPTABLES_MOD_EXTRA
        select BR2_PACKAGE_IPTABLES_MOD_FILTER
+       select BR2_PACKAGE_IPTABLES_MOD_IMQ
        select BR2_PACKAGE_IPTABLES_MOD_IPOPT
        select BR2_PACKAGE_IPTABLES_MOD_IPSEC
        select BR2_PACKAGE_IPTABLES_MOD_NAT
@@ -69,6 +70,14 @@ config BR2_PACKAGE_IPTABLES_MOD_NAT
        help
          Iptables (IPv4) extensions for different NAT targets
 
+config BR2_PACKAGE_IPTABLES_MOD_IMQ
+       tristate "iptables-mod-imq - Iptables extensions for Intermediate Queuing Device QoS-support"
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_IPTABLES
+       select BR2_PACKAGE_KMOD_IMQ
+       help
+         Iptables (IPv4) extensions for Intermediate Queuing Device QoS-support
+
 config BR2_PACKAGE_IPTABLES_MOD_ULOG
        tristate "iptables-mod-ulog - Iptables extensions for user-space packet logging"
        default m if CONFIG_DEVEL
index 7cea99c62e3fa48bd43698f671cdb27df8f24f8e..a8493ed8bf3d81527ae12fdbb36db65e22813412 100644 (file)
@@ -42,7 +42,7 @@ $(eval $(call PKG_template,IP6TABLES,ip6tables,$(PKG_VERSION)-$(PKG_RELEASE),$(A
 $(eval $(call PKG_template,IPTABLES_MOD_CONNTRACK,iptables-mod-conntrack,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,IPTABLES_MOD_EXTRA,iptables-mod-extra,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,IPTABLES_MOD_FILTER,iptables-mod-filter,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,IPTABLES_MOD_IMQ,iptables-mod-img,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,IPTABLES_MOD_IMQ,iptables-mod-imq,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,IPTABLES_MOD_IPOPT,iptables-mod-ipopt,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,IPTABLES_MOD_IPSEC,iptables-mod-ipsec,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,IPTABLES_MOD_NAT,iptables-mod-nat,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
diff --git a/openwrt/package/iptables/ipkg/iptables-mod-imq.control b/openwrt/package/iptables/ipkg/iptables-mod-imq.control
new file mode 100644 (file)
index 0000000..d1e46d2
--- /dev/null
@@ -0,0 +1,5 @@
+Package: iptables-mod-imq
+Priority: optional
+Section: net
+Depends: kmod-imq
+Description: Iptables (IPv4) extensions for Intermediate Queuing Device QoS-support