projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ac9e2d9
)
wl1251: enable sparse endianess check by default
author
Luciano Coelho
<coelho@ti.com>
Wed, 21 Dec 2011 20:36:29 +0000
(22:36 +0200)
committer
Luciano Coelho
<coelho@ti.com>
Wed, 15 Feb 2012 06:38:27 +0000
(08:38 +0200)
Following the good example of the Intel (and more recently Atheros)
drivers, enable endianess check by default when running sparse.
Signed-off-by: Luciano Coelho <coelho@ti.com>
drivers/net/wireless/wl1251/Makefile
patch
|
blob
|
history
diff --git
a/drivers/net/wireless/wl1251/Makefile
b/drivers/net/wireless/wl1251/Makefile
index 58b4f935a3f634f89157e32389e90cbf29898310..a5c6328b5f725bd3e92e8292df48328f219b08f2 100644
(file)
--- a/
drivers/net/wireless/wl1251/Makefile
+++ b/
drivers/net/wireless/wl1251/Makefile
@@
-6,3
+6,5
@@
wl1251_sdio-objs += sdio.o
obj-$(CONFIG_WL1251) += wl1251.o
obj-$(CONFIG_WL1251_SPI) += wl1251_spi.o
obj-$(CONFIG_WL1251_SDIO) += wl1251_sdio.o
+
+ccflags-y += -D__CHECK_ENDIAN__