modemmanager: don't flag the 'device' option as 'device' type
authorAleksander Morgado <aleksander@aleksander.es>
Wed, 20 Nov 2019 11:57:04 +0000 (12:57 +0100)
committerAleksander Morgado <aleksander@aleksander.es>
Wed, 27 Nov 2019 08:28:10 +0000 (09:28 +0100)
Unlike other modem protocol handlers like the ones implemented by uqmi
or umbim, in the modemmanager protocol handler the 'device' option
does not specify a device node in /dev. Therefore, we shouldn't flag
the option as 'device' type (dt_type_device).

Signed-off-by: Aleksander Morgado <aleksander@aleksander.es>
net/modemmanager/Makefile
net/modemmanager/files/modemmanager.proto

index 0c73a8880be9f46354b25a180758707efd9ef544..eb8f051fe29d4a98989f19fae4b12b50c00d4e4e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=modemmanager
 PKG_VERSION:=1.12.0
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=ModemManager-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.freedesktop.org/software/ModemManager
index b7d99f41d12655ba77ed7574ea2bbfad3b451e26..536073dce4d2a3337daa43c12e51d6f4e45c285b 100755 (executable)
@@ -306,7 +306,7 @@ modemmanager_disconnected_method_common() {
 proto_modemmanager_init_config() {
        available=1
        no_device=1
-       proto_config_add_string  "device:device"
+       proto_config_add_string  device
        proto_config_add_string  apn
        proto_config_add_string  username
        proto_config_add_string  password