intltool: Update to 0.51
authorRosen Penev <rosenp@gmail.com>
Thu, 2 Aug 2018 01:34:08 +0000 (18:34 -0700)
committerRosen Penev <rosenp@gmail.com>
Thu, 2 Aug 2018 01:34:08 +0000 (18:34 -0700)
Upstream has moved. @GNOME only has old versions.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/intltool/Makefile
libs/intltool/patches/100-optional-perl-xml-parser.patch

index cebae5370ca277bc8ef58a6e69b069edda6c5cd3..4c672f2f9cc8a624470a8f88d26bf75d68ee4c08 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=intltool
-PKG_LIBVER:=0.40
-PKG_VERSION:=$(PKG_LIBVER).6
-PKG_RELEASE:=3
+PKG_LIBVER:=0.51
+PKG_VERSION:=$(PKG_LIBVER).0
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@GNOME/intltool/$(PKG_LIBVER)
-PKG_HASH:=4d1e5f8561f09c958e303d4faa885079a5e173a61d28437d0013ff5efc9e3b64
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://launchpad.net/intltool/trunk/$(PKG_VERSION)/+download
+PKG_HASH:=67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
 
 PKG_HOST_ONLY:=1
@@ -27,7 +27,7 @@ define Package/intltool
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=set of tools to centralize translation using GNU gettext
-  URL:=http://www.freedesktop.org/wiki/Software/intltool
+  URL:=https://www.freedesktop.org/wiki/Software/intltool
   BUILDONLY:=1
 endef
 
index 4615d1d9534404b3ae61cbb1c5b75d3bb51edd9f..32474ba7080c66af75c196ef705b833c950d4547 100644 (file)
@@ -1,22 +1,22 @@
---- a/configure.in
-+++ b/configure.in
-@@ -25,7 +25,7 @@ AC_MSG_CHECKING([for XML::Parser])
+--- a/configure.ac
++++ b/configure.ac
+@@ -27,7 +27,7 @@ AC_MSG_CHECKING([for XML::Parser])
  if `$PERL -e "require XML::Parser" 2>/dev/null`; then
     AC_MSG_RESULT([ok])
  else
 -   AC_MSG_ERROR([XML::Parser perl module is required for intltool])
-+   AC_MSG_RESULT([XML::Parser perl module is required for some intltool utilitities])
++   AC_MSG_RESULT([XML::Parser perl module is required for intltool])
  fi
+ AC_PATH_PROG(BZR, bzr)
  
- AC_OUTPUT([
 --- a/intltool.m4
 +++ b/intltool.m4
-@@ -127,7 +127,7 @@ if test "x$2" != "xno-xml"; then
+@@ -148,7 +148,7 @@ if test "x$2" != "xno-xml"; then
     if `$INTLTOOL_PERL -e "require XML::Parser" 2>/dev/null`; then
         AC_MSG_RESULT([ok])
     else
 -       AC_MSG_ERROR([XML::Parser perl module is required for intltool])
-+       AC_MSG_RESULT([XML::Parser perl module is required for some intltool utilitities])
++       AC_MSG_RESULT([XML::Parser perl module is required for intltool])
     fi
  fi