ruby: disable documentation for host build
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:27 +0000 (00:56 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:27 +0000 (00:56 +0000)
Building the documentation for the host requires a bunch of tools that systems
might not have, simply disable it which also speeds up the build time.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39796

lang/ruby/Makefile

index c53937b914c322dbed3001924cc06fcf34cfe422..7b67ebefbfcddbc928efa6d0578cc9438ba74466 100644 (file)
@@ -202,6 +202,10 @@ $(call Package/ruby/Default)
   DEPENDS:=ruby +zlib
 endef
 
+HOST_CONFIGURE_ARGS += \
+       --disable-install-doc \
+       --disable-install-rdoc \
+       --disable-install-capi
 
 CONFIGURE_ARGS += \
        --enable-shared \