python: link with static libs of ssl, crypto for host builds
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 11 Jan 2017 09:06:57 +0000 (11:06 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 11 Jan 2017 13:12:20 +0000 (15:12 +0200)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/Makefile

index ae9a2146ebe5e312ea71f10db43d0315d2bcbdcd..ed708b57821e3c3f8c71909cd370bce0f8ccd1c8 100644 (file)
@@ -229,6 +229,9 @@ define PyPackage/python/filespec
 -|$(PYTHON_PKG_DIR)
 endef
 
+HOST_LDFLAGS += \
+       $$$$(pkg-config --static --libs libcrypto libssl)
+
 HOST_CONFIGURE_ARGS+= \
        --without-cxx-main \
        --without-pymalloc \