projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8ab02e0
)
selftests: x86: override clean in lib.mk to fix warnings
author
Shuah Khan
<shuahkh@osg.samsung.com>
Fri, 21 Apr 2017 22:26:16 +0000
(16:26 -0600)
committer
Shuah Khan
<shuahkh@osg.samsung.com>
Thu, 27 Apr 2017 14:05:23 +0000
(08:05 -0600)
Add override with EXTRA_CLEAN for lib.mk clean to fix the following
warnings from clean target run.
Makefile:44: warning: overriding recipe for target 'clean'
../lib.mk:55: warning: ignoring old recipe for target 'clean'
Signed-off-by: Shuah Khan <shuahkh@osg.samsung.com>
tools/testing/selftests/x86/Makefile
patch
|
blob
|
history
diff --git
a/tools/testing/selftests/x86/Makefile
b/tools/testing/selftests/x86/Makefile
index 38e0a9ca5d71154c4d1d32ad7af9ca9154893a33..97f187e2663f3adaf37a50674c36aafec11d291f 100644
(file)
--- a/
tools/testing/selftests/x86/Makefile
+++ b/
tools/testing/selftests/x86/Makefile
@@
-40,8
+40,7
@@
all_32: $(BINARIES_32)
all_64: $(BINARIES_64)
-clean:
- $(RM) $(BINARIES_32) $(BINARIES_64)
+EXTRA_CLEAN := $(BINARIES_32) $(BINARIES_64)
$(BINARIES_32): $(OUTPUT)/%_32: %.c
$(CC) -m32 -o $@ $(CFLAGS) $(EXTRA_CFLAGS) $^ -lrt -ldl -lm