bridge-utils: fix conflict with busybox brctl
authorKonstantin Demin <rockdrilla@gmail.com>
Fri, 7 Jun 2019 19:52:44 +0000 (22:52 +0300)
committerYousong Zhou <yszhou4tech@gmail.com>
Fri, 12 Jul 2019 09:11:12 +0000 (09:11 +0000)
Busybox brctl applet conflicts with the version from bridge-utils.
Fix this by using ALTERNATIVE support for brctl in bridge-utils.

Fixes openwrt/packages#8812

Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
[PKG_RELEASE bump]
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
(cherry-picked from commit fabd9efdea6a57dfc58d9c57f5b31cb1ee4aa9a0)

net/bridge-utils/Makefile

index 00c63ea44d81cd84f70c8891884d91c640637c9a..2d4d8e8dadd2ed4fae85bcd4489addadcf97489e 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=bridge-utils
 PKG_VERSION:=1.5
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/bridge-utils.git
@@ -31,6 +31,7 @@ define Package/bridge
   TITLE:=Ethernet bridging configuration utility
   URL:=http://bridge.sourceforge.net/
   PKG_MAINTAINER:=Nikolay Martynov <mar.kolya@gmail.com>
+  ALTERNATIVES:=300:/usr/sbin/brctl:/usr/libexec/bridge-utils-brctl
 endef
 
 define Package/bridge/description
@@ -44,15 +45,8 @@ CONFIGURE_ARGS += \
        --with-linux-headers="$(LINUX_DIR)" \
 
 define Package/bridge/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/sbin
-endef
-
-define Package/bridge/prerm
-#!/bin/sh
-$${IPKG_INSTROOT}/bin/busybox brctl -h 2>&1 | grep -q BusyBox && \
-ln -sf ../../bin/busybox $${IPKG_INSTROOT}/usr/sbin/brctl
-exit 0
+       $(INSTALL_DIR) $(1)/usr/libexec
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/libexec/bridge-utils-brctl
 endef
 
 $(eval $(call BuildPackage,bridge))