apinger: fix compilation with GCC 10
authorRosen Penev <rosenp@gmail.com>
Fri, 17 Jul 2020 23:15:47 +0000 (16:15 -0700)
committerRosen Penev <rosenp@gmail.com>
Sat, 18 Jul 2020 03:35:34 +0000 (20:35 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/apinger/Makefile
net/apinger/patches/020-gcc10.patch [new file with mode: 0644]

index 1c52c7578e7711798f19404eb71e8d9cecfbb7f7..f6837cec410c192d2fdaad8dc5acb4410351188a 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=apinger
 PKG_SOURCE_DATE:=2015-04-09
 PKG_SOURCE_VERSION:=78eb328721ba1a10571c19df95acddcb5f0c17c8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/Jajcus/apinger
diff --git a/net/apinger/patches/020-gcc10.patch b/net/apinger/patches/020-gcc10.patch
new file mode 100644 (file)
index 0000000..3272804
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/apinger.h
++++ b/src/apinger.h
+@@ -111,7 +111,7 @@ struct piped_info {
+ };
+ #endif
+-struct target *targets;
++extern struct target *targets;
+ extern int foreground;
+ extern char *config_file;