projects
/
openwrt
/
staging
/
florian.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
62905b0
)
ep93xx: Package ep93xx-eth kernel module
author
Florian Fainelli
<f.fainelli@gmail.com>
Fri, 23 Dec 2016 02:29:59 +0000
(18:29 -0800)
committer
Florian Fainelli
<f.fainelli@gmail.com>
Tue, 9 May 2017 03:41:56 +0000
(20:41 -0700)
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
target/linux/ep93xx/modules.mk
patch
|
blob
|
history
diff --git
a/target/linux/ep93xx/modules.mk
b/target/linux/ep93xx/modules.mk
index 50c049da3380f671404991087a7be65f1c33ce94..0042a7c3236d32f3753ff61b5e010e363b7718a5 100644
(file)
--- a/
target/linux/ep93xx/modules.mk
+++ b/
target/linux/ep93xx/modules.mk
@@
-101,3
+101,18
@@
endef
$(eval $(call KernelPackage,touchscreen-ep93xx))
+define KernelPackage/eth-ep93xx
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=EP93xx Ethernet driver
+ DEPENDS:=+kmod-mii
+ FILES:=$(LINUX_DIR)/drivers/net/ethernet/cirrus/ep93xx_eth.ko
+ KCONFIG:=CONFIG_EP93XX_ETH
+ AUTOLOAD:=$(call AutoProbe,ep93xx_eth)
+endef
+
+define KernelPackage/eth-ep93xx/description
+ Kernel module for the Cirrus Logic EP93xx SoC Ethernet core
+endef
+
+$(eval $(call KernelPackage,eth-ep93xx))
+