tcsh: Update to 6.22.02
authorRosen Penev <rosenp@gmail.com>
Fri, 3 Jan 2020 06:27:19 +0000 (22:27 -0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 6 Jan 2020 01:11:46 +0000 (17:11 -0800)
Updated URL list. Changed to HTTPS also.

Added PKG_BUILD_PARALLEL for faster compilation.

Added PKG_INSTALL as is standard with most packages.

Small optimization to shell script.

Added two patches to fix compilation. Refreshed the other one.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/tcsh/Makefile
utils/tcsh/patches/001-sysmalloc.patch
utils/tcsh/patches/010-wint.patch [new file with mode: 0644]
utils/tcsh/patches/020-cross.patch [new file with mode: 0644]

index 49d1552e4490bd9fb853c7098f3ac53f67b4868a..5200aabbb74f0c8306700a8cd484579cbc076252 100644 (file)
@@ -7,32 +7,36 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tcsh
-PKG_VERSION:=6.20.00
-PKG_RELEASE:=2
+PKG_VERSION:=6.22.02
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
-       http://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/ \
-       http://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/old/ \
-       ftp://ftp.astron.com/pub/tcsh/ \
-       ftp://ftp.astron.com/pub/tcsh/old
-PKG_HASH:=b89de7064ab54dac454a266cfe5d8bf66940cb5ed048d0c30674ea62e7ecef9d
+       https://astron.com/pub/tcsh/ \
+       https://astron.com/pub/tcsh/old \
+       https://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh \
+       https://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/old
+PKG_HASH:=ed287158ca1b00ba477e8ea57bac53609838ebcfd05fcb05ca95021b7ebe885b
 
+PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=Copyright
 PKG_CPE_ID:=cpe:/a:tcsh:tcsh
 
-PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/tcsh
   SECTION:=utils
   CATEGORY:=Utilities
   SUBMENU:=Shells
   TITLE:=Enhanced Berkeley UNIX C shell
-  DEPENDS:=+libncurses
-  URL:=http://www.tcsh.org/
+  DEPENDS:=+libncurses $(ICONV_DEPENDS)
+  URL:=https://www.tcsh.org/
 endef
 
 define Package/tcsh/description
@@ -48,14 +52,15 @@ endef
 
 define Package/tcsh/postinst
 #!/bin/sh
-grep tcsh $${IPKG_INSTROOT}/etc/shells || \
-       echo "/bin/tcsh" >> $${IPKG_INSTROOT}/etc/shells
-       echo "/bin/csh" >> $${IPKG_INSTROOT}/etc/shells
+grep tcsh $${IPKG_INSTROOT}/etc/shells || { \
+       echo "/bin/tcsh"
+       echo "/bin/csh"
+} >> $${IPKG_INSTROOT}/etc/shells
 endef
 
 define Package/tcsh/install
        $(INSTALL_DIR) $(1)/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/tcsh $(1)/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tcsh $(1)/bin/
        ln -sf tcsh $(1)/bin/csh
 endef
 
index b22c01898344e3829b788b3df3ee632da0fbd411..7cc7e06c60aa1467e6d2345d79c5ab91698633b7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/config_f.h               
 +++ b/config_f.h
-@@ -139,11 +139,8 @@
+@@ -138,11 +138,8 @@
   *            This can be much slower and no memory statistics will be
   *            provided.
   */
diff --git a/utils/tcsh/patches/010-wint.patch b/utils/tcsh/patches/010-wint.patch
new file mode 100644 (file)
index 0000000..2f6fc94
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/ed.inputl.c
++++ b/ed.inputl.c
+@@ -668,9 +668,9 @@ int
+ GetCmdChar(Char ch)
+ {
+ #ifndef WINNT_NATIVE // We use more than 256 for various extended keys 
+-    wint_t c = ch & CHAR;
++    Char c = ch & CHAR;
+ #else
+-    wint_t c = ch;
++    Char c = ch;
+ #endif
+     return c < NT_NUM_KEYS ? CurrentKeyMap[c] : F_INSERT;
+ }
diff --git a/utils/tcsh/patches/020-cross.patch b/utils/tcsh/patches/020-cross.patch
new file mode 100644 (file)
index 0000000..b1ed1ec
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -447,7 +447,7 @@ pure:$(P) ${OBJS}
+ gethost:  gethost.c sh.err.h tc.const.h sh.h
+       rm -f gethost
+-      ${CC_FOR_GETHOST} -o gethost ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} $(srcdir)/gethost.c
++      ${CC_FOR_GETHOST} -o gethost $(srcdir)/gethost.c
+ tc.defs.c:    gethost host.defs
+       @rm -f $@.tmp