obfs4proxy: Remove build dependencies
authorJeffery To <jeffery.to@gmail.com>
Wed, 20 Mar 2019 20:42:08 +0000 (04:42 +0800)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 21 Mar 2019 07:13:12 +0000 (15:13 +0800)
The Go compiler can now manage the build dependencies by itself, as
obfs4proxy has been ported to a Go module.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
net/obfs4proxy/Makefile

index 699de9aeaab4bd284244354c0992e72a178a903d..9b4c4332f9d8a67303b5d7ef39dfece25c55be12 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=obfs4proxy
 PKG_VERSION:=0.0.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=obfs4-$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://gitlab.com/yawning/obfs4/-/archive/$(PKG_NAME)-$(PKG_VERSION)/
@@ -45,12 +45,6 @@ define Package/golang-gitlab-yawning-obfs4-dev
 $(call Package/obfs4proxy/Default)
 $(call GoPackage/GoSubMenu)
   TITLE+= (source files)
-  DEPENDS+= \
-    +golang-github-agl-ed25519-dev \
-    +golang-github-dchest-siphash-dev \
-    +golang-golang-x-crypto-dev \
-    +golang-golang-x-net-dev \
-    +golang-torproject-pluggable-transports-goptlib-dev
   PKGARCH:=all
 endef