ooniprobe: remove unused package
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Fri, 13 Oct 2023 06:57:18 +0000 (08:57 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Mon, 23 Oct 2023 07:59:58 +0000 (09:59 +0200)
This package is not maintained anymore in the OpenWrt packages feed
and since we updated Go to 1.21 version, it is not compiled either.

Let's hope that with removing this package from our feed,
someone will step it and become a maintainer to take care of this package.

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
(cherry picked from commit 5a917a2a1cd068081d6f30e6ffc282ae977423bb)

net/ooniprobe/Makefile [deleted file]
net/ooniprobe/test.sh [deleted file]

diff --git a/net/ooniprobe/Makefile b/net/ooniprobe/Makefile
deleted file mode 100644 (file)
index bb7cf42..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-#
-# Copyright (C) 2020-2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ooniprobe
-PKG_VERSION:=3.18.0
-PKG_RELEASE:=1
-
-PKG_SOURCE:=probe-cli-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://codeload.github.com/ooni/probe-cli/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=d28c050226c9282d7155da6cabf5547ddd43dc11eecacc485b6c05161c2d1d88
-
-PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
-PKG_LICENSE:=GPL-3.0-or-later
-PKG_LICENSE_FILES:=LICENSE
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/probe-cli-$(PKG_VERSION)
-PKG_BUILD_DEPENDS:=golang/host
-PKG_BUILD_PARALLEL:=1
-PKG_BUILD_FLAGS:=no-mips16
-
-GO_PKG:=github.com/ooni/probe-cli
-GO_PKG_BUILD_PKG:=github.com/ooni/probe-cli/v3/cmd/ooniprobe
-
-include $(INCLUDE_DIR)/package.mk
-include ../../lang/golang/golang-package.mk
-
-define Package/ooniprobe
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=OONI probe-cli
-  URL:=https://ooni.org
-  DEPENDS:=$(GO_ARCH_DEPENDS)
-endef
-
-define Package/ooniprobe/description
-  The next generation of Open Observatory of Network Interference (OONI)
-  Probe Command Line Interface.
-endef
-
-# Workaround for musl 1.2.4 compability in mattn/go-sqlite3
-# https://github.com/mattn/go-sqlite3/issues/1164
-ifneq ($(CONFIG_USE_MUSL),)
-  TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
-endif
-
-$(eval $(call GoBinPackage,ooniprobe))
-$(eval $(call BuildPackage,ooniprobe))
diff --git a/net/ooniprobe/test.sh b/net/ooniprobe/test.sh
deleted file mode 100644 (file)
index 9ecab82..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-ooniprobe version | grep "$2"