-diff -urN orig/heyu-2.0beta.2/Makefile heyu-2.0beta.2/Makefile
---- orig/heyu-2.0beta.2/Makefile 1970-01-01 01:00:00.000000000 +0100
-+++ heyu-2.0beta.2/Makefile 2006-01-07 01:53:25.000000000 +0100
-@@ -0,0 +1,183 @@
+--- /dev/null
++++ b/Makefile
+@@ -0,0 +1,252 @@
+# Makefile for HEYU, a program to control an X10 CM11A computer interface.
+# This makefile is generated by the Configure program.
+#
+## by the Configure program
+
+SRCS = date.c erase.c info.c message.c relay.c \
-+ relay_aux.c monitor.c reset.c setclock.c stop.c \
++ monitor.c reset.c setclock.c stop.c \
+ tty.c x10.c xread.c xwrite.c status.c cm11a.c \
+ eeprom.c process.c sun.c cmd.c config.c x10state.c \
-+ poll.c modules.c cm10a.c cm17a.c tty_aux.c xsync.c x10aux.c timing.c
-+
++ poll.c modules.c cm17a.c xsync.c timing.c cm10a.c \
++ tty_aux.c relay_aux.c x10aux.c rfxcom.c digimax.c oregon.c
+OBJS = date.o erase.o info.o message.o relay.o \
-+ relay_aux.o monitor.o reset.o setclock.o stop.o \
++ monitor.o reset.o setclock.o stop.o \
+ tty.o x10.o xread.o xwrite.o status.o cm11a.o \
+ eeprom.o process.o sun.o cmd.o config.o x10state.o \
-+ poll.o modules.o cm10a.o cm17a.o tty_aux.o xsync.o x10aux.o timing.o
++ poll.o modules.o cm17a.o xsync.o timing.o cm10a.o \
++ tty_aux.o relay_aux.o x10aux.o rfxcom.o digimax.o oregon.o
+
+OTHERSRC = README README2 Makefile x10config.sample protocol.txt eeprom.h \
+ x10.sched.sample heyu.1 x10.h x10config.5 x10cm17a.5 \
+ history.txt version.h heyufaq.txt x10sched.5 process.h sun.h \
-+ x10scripts.5 Configure Makefile.in install.sh INSTALL LICENSE
++ x10scripts.5 Configure Makefile.in install.sh INSTALL LICENSE \
++ README.cm10a x10aux.5 x10state.h rfxcom.h digimax.h oregon.h x10rfxsensors.5\
++ x10rfxmeters.5 x10digimax.5 x10oregon.5
+
+EVERYTHING = $(OTHERSRC) $(SRCS)
+
-+all: heyu
++all: heyu
+
+heyu: $(OBJS) version.h
+ $(CC) $(LDFLAGS) -o heyu $(OBJS) $(LIBS)
+ @echo `id` >usergroup.tmp
+ @echo ${HOME} >userhome.tmp
++ @echo ""
+ @echo "** Now become root and run 'make install' **"
++ @echo ""
+
-+$(OBJS): x10.h process.h sun.h
++$(OBJS): x10.h process.h sun.h Makefile
+
+eeprom.o: eeprom.h
++info.o: version.h
++x10state.o: x10state.c x10state.h rfxcom.h digimax.h oregon.h
++rfxcom.o: rfxcom.c x10state.h rfxcom.h
++digimax.o: digimax.c x10state.h digimax.h
++oregon.o: oregon.c x10state.h oregon.h
++modules.o: modules.c oregon.h
++poll.o: poll.c oregon.h
+
+install: $(BIN)/heyu $(MAN)/heyu.1 $(MAN5)/x10config.5 $(MAN5)/x10sched.5 \
-+ $(MAN5)/x10scripts.5
++ $(MAN5)/x10scripts.5 $(MAN5)/x10cm17a.5 $(MAN5)/x10aux.5 \
++ $(MAN5)/x10rfxsensors.5 $(MAN5)/x10rfxmeters.5 $(MAN5)/x10digimax.5 \
++ $(MAN5)/x10oregon.5
++
++maninstall: $(MAN)/heyu.1 $(MAN5)/x10config.5 $(MAN5)/x10sched.5 \
++ $(MAN5)/x10scripts.5 $(MAN5)/x10cm17a.5 $(MAN5)/x10aux.5 \
++ $(MAN5)/x10rfxsensors.5 $(MAN5)/x10rfxmeters.5 \
++ $(MAN5)/x10digimax.5 $(MAN5)/x10oregon.5
+
+uninstall:
+ rm -f $(BIN)/heyu
+ rm -f $(MAN5)/x10config.5
+ rm -f $(MAN5)/x10sched.5
+ rm -f $(MAN5)/x10scripts.5
++ rm -f $(MAN5)/x10cm17a.5
++ rm -f $(MAN5)/x10aux.5
++ rm -f $(MAN5)/x10rfxsensors.5
++ rm -f $(MAN5)/x10rfxmeters.5
++ rm -f $(MAN5)/x10digimax.5
++ rm -f $(MAN5)/x10oregon.5
+
+$(BIN)/heyu: heyu
+ mkdir -p -m 755 $(BIN)
+ cp x10scripts.5 $(MAN5)
+ chmod 644 $(MAN5)/x10scripts.5
+
++$(MAN5)/x10cm17a.5: x10cm17a.5
++ mkdir -p -m 755 $(MAN5)
++ cp x10cm17a.5 $(MAN5)
++ chmod 644 $(MAN5)/x10cm17a.5
++
++$(MAN5)/x10aux.5: x10aux.5
++ mkdir -p -m 755 $(MAN5)
++ cp x10aux.5 $(MAN5)
++ chmod 644 $(MAN5)/x10aux.5
++
++$(MAN5)/x10rfxsensors.5: x10rfxsensors.5
++ mkdir -p -m 755 $(MAN5)
++ cp x10rfxsensors.5 $(MAN5)
++ chmod 644 $(MAN5)/x10rfxsensors.5
++
++$(MAN5)/x10rfxmeters.5: x10rfxmeters.5
++ mkdir -p -m 755 $(MAN5)
++ cp x10rfxmeters.5 $(MAN5)
++ chmod 644 $(MAN5)/x10rfxmeters.5
++
++$(MAN5)/x10digimax.5: x10digimax.5
++ mkdir -p -m 755 $(MAN5)
++ cp x10digimax.5 $(MAN5)
++ chmod 644 $(MAN5)/x10digimax.5
++
++$(MAN5)/x10oregon.5: x10oregon.5
++ mkdir -p -m 755 $(MAN5)
++ cp x10oregon.5 $(MAN5)
++ chmod 644 $(MAN5)/x10oregon.5
++
+lint:
+ lint $(DFLAGS) $(SRCS)
+
+shar: x10_heyu.shar.1 x10_heyu.shar.2
+
+x10.o: x10.c version.h
++process.o: process.c version.h
++xread.o: xread.c local.h
+
+ci: $(SRCS) index.html Makefile
+ @ for FL in $+ ; do \
+ mkdir distro.dir
+ cp -p $(EVERYTHING) distro.dir
+ cp -p release_notes.txt distro.dir
++ cp -p INSTALL distro.dir/README.INSTALL
+ rm distro.dir/Makefile
+
++man2html:
++ man2html heyu.1 >./html/heyu.1.html
++ man2html x10config.5 >./html/x10config.5.html
++ man2html x10scripts.5 > ./html/x10scripts.5.html
++ man2html x10sched.5 > ./html/x10sched.5.html
++ man2html x10aux.5 > ./html/x10aux.5.html
++ man2html x10cm17a.5 > ./html/x10cm17a.5.html
++ man2html x10rfxsensors.5 > ./html/x10rfxsensors.5.html
++ man2html x10rfxmeters.5 > ./html/x10rfxmeters.5.html
++ man2html x10digimax.5 > ./html/x10digimax.5.html
++ man2html x10oregon.5 > ./html/x10oregon.5.html
+
+beta: x10_beta.tgz
+
+$(EVERYTHING):
+## co -r$(revision) $@
+
-diff -urN orig/heyu-2.0beta.2/local.h heyu-2.0beta.2/local.h
---- orig/heyu-2.0beta.2/local.h 1970-01-01 01:00:00.000000000 +0100
-+++ heyu-2.0beta.2/local.h 2006-01-07 01:54:13.000000000 +0100
+--- /dev/null
++++ b/local.h
@@ -0,0 +1,3 @@
+#define USESIGINT 1'
+#define SPOOLDIR "/tmp"