bottom: New package
authorLuca Barbato <lu_zero@gentoo.org>
Thu, 17 Aug 2023 12:30:58 +0000 (14:30 +0200)
committerTianling Shen <cnsztl@gmail.com>
Wed, 23 Aug 2023 00:35:02 +0000 (08:35 +0800)
Bottom is a top/htop workalike with few additional features, written in
rust.

Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
admin/bottom/Makefile [new file with mode: 0644]

diff --git a/admin/bottom/Makefile b/admin/bottom/Makefile
new file mode 100644 (file)
index 0000000..bdd049a
--- /dev/null
@@ -0,0 +1,38 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2023 Luca Barbato
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bottom
+PKG_VERSION:=0.9.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/ClementTsang/bottom/tar.gz/$(PKG_VERSION)?
+PKG_HASH:=199123ef354bcabaa8a2e3b7b477b324f5b647d503a2599d08296733846eea6e
+
+PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=rust/host
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/rust/rust-package.mk
+
+define Package/bottom
+  SECTION:=admin
+  CATEGORY:=Administration
+  TITLE:=Interactive processes viewer
+  DEPENDS:=$(RUST_ARCH_DEPENDS)
+  URL:=https://github.com/ClementTsang/bottom
+endef
+
+define Package/bottom/description
+  A customizable cross-platform graphical process/system monitor
+  for the terminal.
+endef
+
+$(eval $(call RustBinPackage,bottom))
+$(eval $(call BuildPackage,bottom))