sslh: add capabilities support
authorGabor Seljan <sgabe@users.noreply.github.com>
Sun, 24 May 2020 16:57:15 +0000 (18:57 +0200)
committerGabor Seljan <sgabe@users.noreply.github.com>
Tue, 26 May 2020 17:59:24 +0000 (19:59 +0200)
Compile with USELIBCAP=1 to make use of POSIX capabilities. This will
save the required capabilities needed for transparent proxying for
unprivileged processes.

Signed-off-by: Gabor Seljan <sgabe@users.noreply.github.com>
net/sslh/Makefile

index e141f99da73b0605fe632558534bb7944cbe25a5..5df307a91b70cd46f47e7f25a76bdce0c384755b 100644 (file)
@@ -26,7 +26,7 @@ define Package/sslh
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
   TITLE:=SSL/SSH multiplexer
-  DEPENDS:=+libconfig +USE_UCLIBC:libpcre +USE_MUSL:libpcre
+  DEPENDS:=+libconfig +libcap +USE_UCLIBC:libpcre +USE_MUSL:libpcre
   URL:=https://rutschle.net/tech/sslh/README.html
 endef
 
@@ -36,6 +36,7 @@ define Package/sslh/conffiles
 endef
 
 MAKE_FLAGS += \
+  USELIBCAP=1 \
   $(if $(CONFIG_USE_GLIBC),USELIBPCRE=,USELIBPCRE=1)
 
 define Package/sslh/install