projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8055ac1
)
add workaround for the jamvm sdk compile - the sdk does not understand DEPENDS:=...
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 4 Apr 2007 15:13:56 +0000
(15:13 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 4 Apr 2007 15:13:56 +0000
(15:13 +0000)
SVN-Revision: 6863
lang/jamvm/Makefile
patch
|
blob
|
history
diff --git
a/lang/jamvm/Makefile
b/lang/jamvm/Makefile
index 23e5f21ba32f19ebb286f6a7c0b39c3d0d01e4a0..7acd9fc72e2fddd58786744d5dcde463f9cd16a7 100644
(file)
--- a/
lang/jamvm/Makefile
+++ b/
lang/jamvm/Makefile
@@
-48,11
+48,13
@@
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) all
endef
-define Package/jamvm/install
+ifneq ($(ARCH),mips)
+ define Package/jamvm/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/jamvm $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/share/jamvm
$(INSTALL_DATA) $(PKG_BUILD_DIR)/lib/classes.zip $(1)/usr/share/jamvm/
-endef
+ endef
+endif
$(eval $(call BuildPackage,jamvm))